dev-ml/lablgtk: bump to 2.18.6
authorAlexis Ballier <aballier@gentoo.org>
Tue, 31 Oct 2017 12:56:25 +0000 (13:56 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 4 Nov 2017 09:37:08 +0000 (10:37 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.4

dev-ml/lablgtk/Manifest
dev-ml/lablgtk/lablgtk-2.18.6.ebuild [new file with mode: 0644]

index 4bdb122b6f3b6ce3cd1b798b0684aecefa22d546..e80db666fe0937a4ce5a2c323eba12aa2cdcc07d 100644 (file)
@@ -1 +1,2 @@
 DIST lablgtk-2.18.5.tar.gz 808005 SHA256 2bf251db21c077fdd26c035ea03edd8fe609187f908e520e87a8ffdd9c36d233 SHA512 7b6ba1a4dfa82cc3bbc502082ff4fccc23cc06ee4f30d01a2e423f3f99e945a4befe450d230b5aa19c5b810e9f46f2838655099d49da2db7c8a2e52eac213024 WHIRLPOOL 009e1fd2a048f6833ac1d745b5fee5d618b9729fa8c73d29f7bd67b6bd5f8a9b81c361ceb69626afe6a3a09b84b98ccbf0a19e9add0329a50a8ebfbcfdaf7b85
+DIST lablgtk-2.18.6.tar.gz 804837 SHA256 4ddca243066418e2a88ac49ebf2d846fac4b667b1b1753efadd078ae777368f8 SHA512 0d30da0e4a93b1693ac6d63161d40c8cd6d9337e105a65f3cc01b013ce7ca04aa5e1a013527cb0728a9b7b7af20d0f4c8b0cc7f9102e553dff3cf8bc83a14e5e WHIRLPOOL 6888d91be3cf3cd6818bb7f01323375f870e505a306699df3a34e7273e9acae05f281af90ffbb58c09a8d5f98fce7e149a34c5a3a145ffe0f535db42a3860ef0
diff --git a/dev-ml/lablgtk/lablgtk-2.18.6.ebuild b/dev-ml/lablgtk/lablgtk-2.18.6.ebuild
new file mode 100644 (file)
index 0000000..41df3e2
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib findlib
+
+IUSE="debug examples glade gnomecanvas sourceview +ocamlopt opengl spell svg"
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://lablgtk.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1726/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception examples? ( lablgtk-examples )"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+       >=dev-lang/ocaml-4.06:=[ocamlopt?]
+       svg? ( >=gnome-base/librsvg-2.2:2 )
+       glade? ( >=gnome-base/libglade-2.0.1 )
+       gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
+       opengl? ( >=dev-ml/lablgl-0.98:=
+               >=x11-libs/gtkglarea-1.9:2 )
+       spell? ( app-text/gtkspell:2 )
+       sourceview? ( x11-libs/gtksourceview:2.0 )
+       dev-ml/camlp4:=
+       "
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+SLOT="2/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+src_configure() {
+       econf $(use_enable debug) \
+               $(use_with svg rsvg) \
+               $(use_with glade) \
+               --without-gnomeui \
+               --without-panel \
+               $(use_with opengl gl) \
+               $(use_with spell gtkspell) \
+               --without-gtksourceview \
+               $(use_with sourceview gtksourceview2) \
+               $(use_with gnomecanvas)
+}
+
+src_compile() {
+       emake -j1 all
+       if use ocamlopt; then
+               emake -j1 opt
+       fi
+}
+
+install_examples() {
+       insinto /usr/share/doc/${P}/examples
+       doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm
+
+       # Install examples for optional components
+       use gnomecanvas && insinto /usr/share/doc/${PF}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
+       use svg && insinto /usr/share/doc/${PF}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
+       use glade && insinto /usr/share/doc/${PF}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
+       use sourceview && insinto /usr/share/doc/${PF}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
+       use opengl && insinto /usr/share/doc/${PF}/examples/GL && doins examples/GL/*.ml
+
+       docompress -x /usr/share/doc/${PF}/examples
+}
+
+src_install () {
+       findlib_src_preinst
+       export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+       emake install DESTDIR="${D}"
+
+       rm -f "${ED}/usr/$(get_libdir)/ocaml/ld.conf"
+
+       dodoc CHANGES README CHANGES.API
+       use examples && install_examples
+}
+
+pkg_postinst () {
+       if use examples; then
+               elog "To run the examples you can use the lablgtk2 toplevel."
+               elog "e.g: lablgtk2 /usr/share/doc/${PF}/examples/testgtk.ml"
+       fi
+}