dev-python/requests-oauthlib: bump 1.3.0
authorJason Zaman <perfinion@gentoo.org>
Wed, 25 Dec 2019 11:19:45 +0000 (19:19 +0800)
committerJason Zaman <perfinion@gentoo.org>
Thu, 26 Dec 2019 02:40:09 +0000 (10:40 +0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
dev-python/requests-oauthlib/Manifest
dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild [new file with mode: 0644]

index 73ff1232df13d928dab04ea81b935860809ef271..931b2b99f31ec56a8c0437926a35626ec1bb9118 100644 (file)
@@ -1 +1,2 @@
 DIST requests-oauthlib-0.7.0.tar.gz 40641 BLAKE2B 3c8e498652df706223dc74404185c14c8f131e0578b1bd2671986507e9f09f7328af7193b0779615499240f67cf6a0c395c103afa63bd6d7c674f2672f64a471 SHA512 9de7f3e2f67507acbd6a711d7c3bc4d598214ab658e7e331f2c56d7a6d084e11df8bfc2449c3ec5e985016404a5e7920e26081bcc3af52d6c91b28d1a69f6ed2
+DIST requests-oauthlib-1.3.0.tar.gz 45449 BLAKE2B b7d0df59eefe801e09329bde8604d09fe0f45eac146172c5ae5f1a77df59229a89c70d78a97fca0f7b546a015e66d6d9dd4ac3efdd4de0100f77f2427106e197 SHA512 0eebd209dad892567de7d37f1482b5c7523eced3a73a68054674b29447d090c885b2388fd6f2db26436f14098833051c8888ace8b137889a4012e010efb0e86b
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..91925c0
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="https://github.com/requests/requests-oauthlib"
+SRC_URI="https://github.com/requests/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# tests fail with network-sandbox
+RESTRICT="!test? ( test )
+       test"
+
+DEPEND="test? (
+                       dev-python/mock[${PYTHON_USEDEP}]
+                       dev-python/requests-mock[${PYTHON_USEDEP}]
+               )"
+RDEPEND="
+       >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]"
+
+#Refrain from a doc build for now
+#python_compile_all() {
+#      use doc && emake -C docs html
+#}
+
+python_test() {
+       esetup.py test
+}