net-irc/inspircd: Add 2.0.29
authorWade Cline <wadecline@hotmail.com>
Sun, 3 May 2020 21:34:16 +0000 (14:34 -0700)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 17:26:08 +0000 (20:26 +0300)
Signed-off-by: Wade Cline <wadecline@hotmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-irc/inspircd/Manifest
net-irc/inspircd/inspircd-2.0.29.ebuild [new file with mode: 0644]

index 3c3a50479874e9c0ef6a48545409d12e65a79571..cbd3522380bb962f02afb2fac3059fd8951efb24 100644 (file)
@@ -1,3 +1,4 @@
 DIST inspircd-2.0.28.tar.gz 735981 BLAKE2B d467b4d31db4cbafeba655a4e129766ec780b2244f1945da6e25e9d70a8c7f946ea6258cc4e1189029a9f3be4d93b3d943f0bd20ccb85951f001268c2e460805 SHA512 0e8082a03e65f350ac423cc0781506c0eb40151d6e8d250067288b2a1d42087f10c159472ad76028aa986f6764180fdc493893984cadc0064715853472fa3e2a
+DIST inspircd-2.0.29.tar.gz 736116 BLAKE2B bd634b81e5a21f4d5e12a4057c4dfb65a241b696be373d24a047594d1d175028dcabff2f28defcf4c340859cfc50637afec755f399c24366e1134c7d69c843f2 SHA512 83da7b089dca8035ffa4f30a2e757661150bb9337aa8124958daa317b44a98fb15fdcb872f8512737b5a39f1b641616eb27c4398d4c8d8fcd40d1f8872bd2052
 DIST inspircd-3.4.0.tar.gz 809845 BLAKE2B 6529d53c3cbff07727eceea5e1eb321bb8b7f6b231b3d5ea3ed0ced01fe5b66c2da83039a1ac11ff49e6536ef482483a9be26762feb30511a0016bab07d6790a SHA512 871fefff5e337dc6228fae223ff7ac534e159b5bfb838419247b1d16339c860b0b939a28dd4610cf3b8c37328b5e6ccba2ddd80adbd27638f4f3fa28e4f99066
 DIST inspircd-3.5.0.tar.gz 835283 BLAKE2B d070d8f299ea2460eb58062b345e9fdef04f1aa94cbedda15bc2ed9c32a7627af383a250359dc77ee6cf2c53dd1841c9a77ce0da236d0b9852c5e9d5a0964aae SHA512 64e7be4b013c418577362b33be73b8f7045f1071ccb2c4e83fdf1a96b98656a3541e20c005bc32532007da21d9ba963f534cd14d16c2e1cf8afcf34b22ffad8c
diff --git a/net-irc/inspircd/inspircd-2.0.29.ebuild b/net-irc/inspircd/inspircd-2.0.29.ebuild
new file mode 100644 (file)
index 0000000..5e0f22c
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://inspircd.github.com/"
+SRC_URI="https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="geoip gnutls ipv6 ldap mysql pcre posix postgres sqlite ssl tre"
+
+RDEPEND="
+       acct-group/inspircd
+       acct-user/inspircd
+       dev-lang/perl
+       ssl? ( dev-libs/openssl:= )
+       geoip? ( dev-libs/geoip )
+       gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+       ldap? ( net-nds/openldap )
+       mysql? ( dev-db/mysql-connector-c:= )
+       postgres? ( dev-db/postgresql:= )
+       pcre? ( dev-libs/libpcre )
+       sqlite? ( >=dev-db/sqlite-3.0 )
+       tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/. )
+PATCHES=( "${FILESDIR}"/${PN}-2.0.27-fix-path-builds.patch )
+
+src_prepare() {
+       default
+
+       # Patch the inspircd launcher with the inspircd user
+       sed -i -e "s/@UID@/${PN}/" "${S}/make/template/${PN}" || die
+}
+
+src_configure() {
+       local extras=""
+
+       use geoip && extras+="m_geoip.cpp,"
+       use gnutls && extras+="m_ssl_gnutls.cpp,"
+       use ldap && extras+="m_ldapauth.cpp,m_ldapoper.cpp,"
+       use mysql && extras+="m_mysql.cpp,"
+       use pcre && extras+="m_regex_pcre.cpp,"
+       use posix && extras+="m_regex_posix.cpp,"
+       use postgres && extras+="m_pgsql.cpp,"
+       use sqlite && extras+="m_sqlite3.cpp,"
+       use ssl && extras+="m_ssl_openssl.cpp,"
+       use tre && extras+="m_regex_tre.cpp,"
+
+       # The first configuration run enables certain "extra" InspIRCd
+       # modules, the second run generates the actual makefile.
+       if [[ -n "${extras}" ]]; then
+               ./configure --disable-interactive --enable-extras=${extras%,}
+       fi
+
+       local myconf=(
+               --with-cc="$(tc-getCXX)"
+               --disable-interactive
+               --prefix="/usr/$(get_libdir)/${PN}"
+               --config-dir="/etc/${PN}"
+               --data-dir="/var/lib/${PN}/data"
+               --log-dir="/var/log/${PN}"
+               --binary-dir="/usr/bin"
+               --module-dir="/usr/$(get_libdir)/${PN}/modules"
+               $(usex ipv6 '' '--disable-ipv6')
+               $(usex gnutls '--enable-gnutls' '')
+               $(usex ssl '--enable-openssl' ''))
+       ./configure "${myconf[@]}"
+}
+
+src_compile() {
+       emake V=1 LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+       emake INSTUID=${PN} DESTDIR="${D}" install
+
+       insinto "/usr/include/${PN}"
+       doins -r include/.
+
+       einstalldocs
+
+       newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+       newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+       keepdir "/var/log/${PN}"
+
+       diropts -o"${PN}" -g"${PN}" -m0700
+       keepdir "/var/lib/${PN}/data"
+}
+
+pkg_postinst() {
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               # This is a new installation
+               elog "You will find example configuration files under "
+               elog "/usr/share/doc/${PN}"
+               elog "Read the ${PN}.conf.example file carefully before "
+               elog "starting the service."
+       fi
+       local pv
+       for pv in ${REPLACING_VERSIONS}; do
+               if ver_test "${pv}" -lt "2.0.24-r1"; then
+                       elog "Starting with 2.0.24-r1 the daemon is no longer started"
+                       elog "with the --logfile option and you are thus expected to define"
+                       elog "logging in the InspIRCd configuration file if you want it."
+                       break
+               fi
+       done
+}