dev-python/chump: add Python 3.8 support
authorLouis Sautier <sbraz@gentoo.org>
Thu, 23 Apr 2020 18:16:29 +0000 (20:16 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Thu, 23 Apr 2020 18:19:06 +0000 (20:19 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/chump/chump-1.6.0.ebuild

index 4eca65a67580960b5caca6da050110530be6c8f9..6ee3f01c296e7b921b9a66f1ebeee445a784767b 100644 (file)
@@ -3,9 +3,7 @@
 
 EAPI=7
 
-# PyPy is not properly supported:
-# https://github.com/karanlyons/chump/issues/17
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -19,10 +17,11 @@ KEYWORDS="~amd64 ~x86"
 IUSE="doc"
 
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
 "
 
+# The package has no test suite
+
 python_prepare_all() {
        sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
        distutils-r1_python_prepare_all