dev-python/jedi: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:11:59 +0000 (13:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:11:59 +0000 (13:11 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/jedi/Manifest
dev-python/jedi/jedi-0.15.1.ebuild [deleted file]

index 75d01ed7bdbc0c89d11fc7da0ef6957cb996b9b6..6dcff772684839d5c212328fb7b7cb3c71243420 100644 (file)
@@ -1,5 +1,4 @@
 DIST jedi-0.14.1.tar.gz 860206 BLAKE2B d1234ceb417f531c5a29908843a47bec5b198abbc848248517f2796d95319e2d930f7c01af9759cb9a3d44a28fb73c4080802642aea1be32f16689e76c1a49ce SHA512 d68c350259921792788917440c9dd6eb923c90eb1b8d0e078a6d428fad852c4d6bbdc74d8caa88ba5a87db344e4b372dc9cfc959d7bab922888d70402fcf4776
-DIST jedi-0.15.1.tar.gz 412356 BLAKE2B a7738e8825b3f578db5e64d50cbf65219b4d2f2f81c45cbae9e3dbb858b0e1ef26d76972c112bfae839daaf73bba0d00b30b5708404d16b0385452500a1c2d35 SHA512 0f6e0185f3f10dbc000f09ddfed7b9596fe5dc270682544173dc156d505618ea14f1f44ede5d2357745ab8ded0b15b2788d064ca4db39fe70196982dd0a16893
 DIST jedi-0.15.2.tar.gz 422520 BLAKE2B f382e4026e1d0388c03b5116ea49fe4abf117c1555ccf0159541557e8d0d344774e15b983fbc66f996f60ae38552bb3b89f3f9cc809ab57f511a01664612f08f SHA512 079d9fc104125d188c72cfc0bd0ccd4de88eb5e7cdfba86e44f840e2427d0ab114bb812dad8e814e502e773d3a59f166547f5f6f287a5eedae64af99e8b5616e
 DIST jedi-0.17.0.tar.gz 462810 BLAKE2B 71eeb3e3fa23786c577fbcb3727a49111d6188c2a5d9e13538123c7c6817b67d457f3bb88423dc9dac6ee09dec89d7281c86166bc771fa0215cd327a4432ebd7 SHA512 562ae25f0c4709cfe36fe4e737d383190d8ad435b3ff580b9fbe966544c8d035cfa29815459ceecfafd704547560a8dc397f841989043e6e18c8f9d639f75399
 DIST typeshed-jedi_v0.15.0.tar.gz 466890 BLAKE2B 7c4956c60646ecb7f21704e3ce95cd38a44e40849e4efba352a0be11c4511fc28d77f32308a3f136cd72833f937f802194ae57f1cdf1d53ae7824ebe4f4bc323 SHA512 46250822eb4aa20203db9b99626e33f2b60ec77072e20dbd94219d782cf204e2cc5a94579b1753c634f931445ad4ef9f0bd7ccfed287d86bca96b945d2eb27c1
diff --git a/dev-python/jedi/jedi-0.15.1.ebuild b/dev-python/jedi/jedi-0.15.1.ebuild
deleted file mode 100644 (file)
index 0552dec..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1
-
-TYPESHED_PV="$(ver_cut 1-2).0"
-TYPESHED_P="typeshed-jedi_v${TYPESHED_PV}"
-
-DESCRIPTION="Autocompletion library for Python"
-HOMEPAGE="https://github.com/davidhalter/jedi"
-SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
-       https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz -> ${TYPESHED_P}.tar.gz"
-
-LICENSE="MIT
-       test? ( Apache-2.0 )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/parso-0.5.0[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-RESTRICT+=" !test? ( test )"
-
-PATCHES=(
-       # mostly pulled from upstream git, except the patch for
-       # test/test_evaluate/test_sys_path.py
-       "${FILESDIR}/jedi-0.15.1-tests.patch"
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
-       # upstream includes this as a submodule ...
-       rmdir "${S}/jedi/third_party/typeshed" || die
-       mv "${WORKDIR}/${TYPESHED_P}" \
-               "${S}/jedi/third_party/typeshed" || die
-
-       # don't run doctests, don't depend on colorama
-       sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
-       sed -i "s: --doctest-modules::" pytest.ini || die
-
-       # speed tests are fragile
-       rm test/test_speed.py || die
-
-       # 'path' completion test does not account for 'path' being a valid
-       # package (i.e. dev-python/path-py)
-       # https://github.com/davidhalter/jedi/issues/1210
-       sed -i -e '/path.*not in/d' test/test_evaluate/test_imports.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # at this point fixing tests on python2 isn't worth the effort...
-       if ! python_is_python3; then
-               ewarn "Skipping tests for ${EPYTHON}"
-               return 0
-       fi
-
-       pytest -vv || die "Tests fail with ${EPYTHON}"
-}