dev-ros/gmapping: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 30 Sep 2015 09:17:47 +0000 (11:17 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 30 Sep 2015 09:18:39 +0000 (11:18 +0200)
Package-Manager: portage-2.2.22

dev-ros/gmapping/Manifest [new file with mode: 0644]
dev-ros/gmapping/gmapping-1.3.8.ebuild [new file with mode: 0644]
dev-ros/gmapping/gmapping-9999.ebuild [new file with mode: 0644]
dev-ros/gmapping/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/gmapping/Manifest b/dev-ros/gmapping/Manifest
new file mode 100644 (file)
index 0000000..03e8e1a
--- /dev/null
@@ -0,0 +1 @@
+DIST slam_gmapping-1.3.8.tar.gz 20533 SHA256 027e31fbe6d8768a746b0eeb93238459b295b15efc0f43f9410afc57d71385d1 SHA512 d7b054296f286a5e61e5f952a29ccff2165503123ab6a89724ec34180fb0f4c452fc0ae81ec853cac170b304095e62cef420431e5aca85a262febc2b5ab5ccf2 WHIRLPOOL ced3e8b2c1f3887afd6df6ea780d3a9a111b29f20db0dedf6af497737e9b2f7c089ce3f673ba309262271c2741a1b73474c2412bbe89c84937c706bad0d95b15
diff --git a/dev-ros/gmapping/gmapping-1.3.8.ebuild b/dev-ros/gmapping/gmapping-1.3.8.ebuild
new file mode 100644 (file)
index 0000000..f532cf5
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/tf
+       dev-ros/openslam_gmapping
+       dev-ros/rosbag_storage
+"
+DEPEND="${RDEPEND}
+       dev-ros/rostest"
diff --git a/dev-ros/gmapping/gmapping-9999.ebuild b/dev-ros/gmapping/gmapping-9999.ebuild
new file mode 100644 (file)
index 0000000..f532cf5
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="CC-BY-NC-SA-2.5"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/tf
+       dev-ros/openslam_gmapping
+       dev-ros/rosbag_storage
+"
+DEPEND="${RDEPEND}
+       dev-ros/rostest"
diff --git a/dev-ros/gmapping/metadata.xml b/dev-ros/gmapping/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>