dev-python/requests-credssp: python 3.7
authorRick Farina <zerochaos@gentoo.org>
Sat, 4 Apr 2020 02:25:27 +0000 (22:25 -0400)
committerRick Farina <zerochaos@gentoo.org>
Sat, 4 Apr 2020 02:25:27 +0000 (22:25 -0400)
added latest release as well

Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
dev-python/requests-credssp/Manifest
dev-python/requests-credssp/requests-credssp-1.1.1.ebuild [new file with mode: 0644]

index cbbec873d6c3d195abf0f1e9bc139634d12b2208..6999308752aa9d2109d5335dbecf871b9bc89dfe 100644 (file)
@@ -1 +1,2 @@
 DIST requests-credssp-1.0.2.tar.gz 21813 BLAKE2B 4626b31e9933e7fe5abdcba59834bedbc14afdd32b21d90124bbb458407213ba8cb92e98394f980f43aacd61de6c0e56e835cf47489ea55338a3dcdd171099e4 SHA512 8a076fc53eee73e24b08f6283b02a48519b9df076222b2e37c145c1d4c1756c29ccc41f0016c5a8ee7f5f7bf76c95fa158016f2cddd42b45a5ab2182939ffae0
+DIST requests-credssp-1.1.1.tar.gz 23274 BLAKE2B ecd36a6e2ad3e8f7b72ce7aaf57a6cd36f4897bf412ecf03d9555eae11c4cbf56eb6e986aa4173626c6624d4ba05777564b17bbe2a87e2d4d42edb15dd3c0aa4 SHA512 729fedf768ca7ee253d395645f25d266c0f917b9319b97973b514ff00e71f4441a79b25b4a89bdb00952ec8544d4db0bc68184bd037fce6b587331c5827c2f71
diff --git a/dev-python/requests-credssp/requests-credssp-1.1.1.ebuild b/dev-python/requests-credssp/requests-credssp-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..e9c0b84
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="HTTPS CredSSP authentication with the requests library"
+HOMEPAGE="https://pypi.org/project/requests-credssp/"
+SRC_URI="mirror://pypi/r/requests-credssp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+       dev-python/ntlm-auth[${PYTHON_USEDEP}]
+       dev-python/pyasn1[${PYTHON_USEDEP}]
+       dev-python/pyopenssl[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"