version bump
authorMichael Sterrett <mr_bones_@gentoo.org>
Mon, 7 Aug 2006 03:51:02 +0000 (03:51 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Mon, 7 Aug 2006 03:51:02 +0000 (03:51 +0000)
Package-Manager: portage-2.1.1_pre4-r3

games-action/trackballs/ChangeLog
games-action/trackballs/files/digest-trackballs-1.1.1
games-action/trackballs/files/digest-trackballs-1.1.2 [new file with mode: 0644]
games-action/trackballs/trackballs-1.1.2.ebuild [new file with mode: 0644]

index f7a7ad6ad5d4d84a6d2946852578486df4087e19..5eccb19d633a8680630c2c999e195c74190cd721 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for games-action/trackballs
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.15 2006/06/07 23:24:51 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.16 2006/08/07 03:51:02 mr_bones_ Exp $
+
+*trackballs-1.1.2 (07 Aug 2006)
+
+  07 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
+  -files/1.0.0-drift.patch, +trackballs-1.1.2.ebuild:
+  version bump
 
   07 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org>
   trackballs-1.1.1.ebuild:
index c9c1fb601f4fcba347c1eb6742bd05703c9d1902..ba123b9f802bae1ba359ae658ba1884b4a229f13 100644 (file)
@@ -1,2 +1,4 @@
 MD5 34c4389aebeab9444ceb887192964fa0 trackballs-1.1.1.tar.gz 6025272
 MD5 68be5fe2ed2381e73863a9858d02064d trackballs-music-1.2.tar.bz2 16064336
+RMD160 5400f47dcf42fe074fce2b465359ace182b857e7 trackballs-music-1.2.tar.bz2 16064336
+SHA256 3266499f8441619dd9332494c8ab99d240544e2469fb045f14a9312136d4ad88 trackballs-music-1.2.tar.bz2 16064336
diff --git a/games-action/trackballs/files/digest-trackballs-1.1.2 b/games-action/trackballs/files/digest-trackballs-1.1.2
new file mode 100644 (file)
index 0000000..1832c43
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 9ea9ca93d87bb0f9ad8abca1b34af594 trackballs-1.1.2.tar.gz 7063832
+RMD160 5abba7f1642d1d47614a1dec36b2e298ed49e395 trackballs-1.1.2.tar.gz 7063832
+SHA256 38ab9273c80da80b1efce68ac1554d2eaf2191913d100a9cd4212d702c17b6ba trackballs-1.1.2.tar.gz 7063832
+MD5 68be5fe2ed2381e73863a9858d02064d trackballs-music-1.2.tar.bz2 16064336
+RMD160 5400f47dcf42fe074fce2b465359ace182b857e7 trackballs-music-1.2.tar.bz2 16064336
+SHA256 3266499f8441619dd9332494c8ab99d240544e2469fb045f14a9312136d4ad88 trackballs-music-1.2.tar.bz2 16064336
diff --git a/games-action/trackballs/trackballs-1.1.2.ebuild b/games-action/trackballs/trackballs-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..b175ccd
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.1.2.ebuild,v 1.1 2006/08/07 03:51:02 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="simple game similar to the classical game Marble Madness"
+HOMEPAGE="http://trackballs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+       mirror://gentoo/${PN}-music-1.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="nls"
+
+DEPEND="virtual/opengl
+       virtual/glu
+       media-libs/libsdl
+       >=dev-util/guile-1.6
+       media-libs/sdl-mixer
+       media-libs/sdl-image
+       media-libs/sdl-ttf
+       sys-libs/zlib
+       nls? ( sys-devel/gettext )"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       sed -i \
+               -e 's/icons//' share/Makefile.in \
+               || die "sed failed"
+       sed -i \
+               -e '/^localedir/s:=.*:=/usr/share/locale:' \
+               src/Makefile.in \
+               po/Makefile.in.in \
+               || die "sed failed"
+}
+
+src_compile() {
+       egamesconf \
+               --disable-dependency-tracking \
+               --with-highscores="${GAMES_STATEDIR}/${PN}-highscores" \
+               $(use_enable nls) \
+               || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       insinto "${GAMES_DATADIR}/${PN}/music"
+       doins "${WORKDIR}"/tb_*.ogg || die "doins failed"
+       dodoc AUTHORS ChangeLog README* NEWS
+       doicon share/icons/*png || die "doicon failed"
+       make_desktop_entry trackballs "Trackballs" trackballs-48x48.png
+       prepgamesdirs
+}