app-doc/eclass-manpages: Switch live ebuild to use dedicated repo
authorMichał Górny <mgorny@gentoo.org>
Fri, 29 Mar 2019 07:50:46 +0000 (08:50 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 29 Mar 2019 08:16:46 +0000 (09:16 +0100)
Switch the live ebuild to use the dedicated script repository rather
than keeping the script in FILESDIR.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-doc/eclass-manpages/eclass-manpages-99999999.ebuild

index 7dfb0d7e0d2af18ef43a5ef1d5b2fcd52e812489..a0e75b5e7e2463422926bc6cfad6bfecd163d538 100644 (file)
@@ -16,15 +16,20 @@ SLOT="0"
 KEYWORDS=""
 IUSE=""
 
+DEPEND="sys-apps/gawk"
+
 src_unpack() {
        git-r3_fetch
+       git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
+
        git-r3_checkout '' '' '' eclass
+       git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
 }
 
 src_compile() {
-       env ECLASSDIR="${S}/eclass" bash "${FILESDIR}"/eclass-to-manpage.sh || die
+       emake ECLASSDIR=eclass
 }
 
 src_install() {
-       doman *.5
+       emake install ECLASSDIR=eclass DESTDIR="${D}" PREFIX=/usr
 }