dev-ruby/multi_json: add 1.14.1
authorHans de Graaff <graaff@gentoo.org>
Tue, 15 Oct 2019 04:35:45 +0000 (06:35 +0200)
committerHans de Graaff <graaff@gentoo.org>
Tue, 15 Oct 2019 04:35:45 +0000 (06:35 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/multi_json/Manifest
dev-ruby/multi_json/multi_json-1.14.1.ebuild [new file with mode: 0644]

index 32a351b6ddfc346813f0a3981066d39b98696fc2..3c3445984858d23339e228bde2e8223d71812365 100644 (file)
@@ -1,2 +1,3 @@
 DIST multi_json-1.13.1.tar.gz 26098 BLAKE2B e82a08a747a092a9094cd7b35b4f933b5ac922a01f45a51b215ca9c4cdb9a083a4808d4bbe67a147ecb57e0b7b7e313c3d896f8cd80c79338c24abc3b90a09f9 SHA512 7c98392bd1c909fcc05249a02a010b561bf6c2d812ae42413d6e8dafa62926d8cb76226ded4c61558a00e5fa531ba33b6f4ef562648c52ba9b552ff7b7e27682
 DIST multi_json-1.14.0.tar.gz 24558 BLAKE2B 78138ab956f71d5875d3ca0d0a7b10fc93fa303648de8515d705ac5e24ed5cf84b425ef4aeebb1ef80862cad373698c2f57eddf17e6558d810edd1a3da2ec342 SHA512 dc2adaa9b5092c653b0a6365ad254a8b920f391123c2625c6ea8168c675346da69f1f003face872e66f493e078f511872d3715e4eef242627b0862cdf4aa3735
+DIST multi_json-1.14.1.tar.gz 24713 BLAKE2B 188d0fa3bf7a46a6cf4a5aa1d613523b4da3dee5061a5288146d1a367835b255f103dec265da9a218dd6dd21ecb38a7ce35d16a758ac7754b440f52c25f0b703 SHA512 19e2b6704a8ed39b8714da449c8961e740198772718ddba3d3b651f71f2b7d8c2c198d9cc16fe290f1df7b1e54d029c01147fdc431a8d2763944a4de802b89d9
diff --git a/dev-ruby/multi_json/multi_json-1.14.1.ebuild b/dev-ruby/multi_json/multi_json-1.14.1.ebuild
new file mode 100644 (file)
index 0000000..776ba06
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/intridea/multi_json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="https://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4:* >=dev-ruby/yajl-ruby-1.0 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:3 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json
+       dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+       sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+       # Remove unimportant rspec options not supported by rspec 2.6.
+       rm .rspec || die
+
+       # Remove specs specific to oj since we don't package oj yet.
+       sed -i -e '/defaults to the best available gem/,/^  end/ s:^:#:' \
+               -e '/Oj does not create symbols on parse/,/^    end/ s:^:#:' \
+               -e '/with Oj.default_settings/,/^    end/ s:^:#:' \
+               -e '/using one-shot parser/,/^  end/ s:^:#:' \
+               -e '/jrjackson/askip "unpackaged"' \
+               spec/multi_json_spec.rb
+
+       # Avoid simplecov which only works with ruby 1.9
+       sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+       # Remove unpackaged and for our purposes unneeded coveralls
+       sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+       # Avoid testing unpackaged adapters
+       rm spec/{gson,nsjsonserialization,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_test() {
+       for t in spec/*_spec.rb; do
+               ${RUBY} -S rspec-3 ${t} || die
+       done
+}