dev-ml/ppx_core: Use proper install method.
authorAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 16:53:27 +0000 (17:53 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 20:59:02 +0000 (21:59 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_core/ppx_core-113.24.00.ebuild

index 8ccbe6a9ed217ace046d16e73b80a422c26e33d6..d00d0966dd88046e20eedd338d68ba07ba6388e4 100644 (file)
@@ -6,10 +6,9 @@ EAPI="5"
 
 inherit oasis
 
-MY_P=${PN/-/_}-${PV}
 DESCRIPTION="Standard library for ppx rewriters"
 HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0/${PV}"
@@ -17,7 +16,23 @@ KEYWORDS="~amd64"
 IUSE=""
 
 DEPEND="dev-ml/ppx_tools:="
-
 RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
 
-S="${WORKDIR}/${MY_P}"
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md
+}