dev-libs/libinput: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Sat, 21 Sep 2019 17:00:12 +0000 (10:00 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 21 Sep 2019 17:11:44 +0000 (10:11 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/libinput/Manifest
dev-libs/libinput/libinput-1.13.4.ebuild [deleted file]
dev-libs/libinput/libinput-1.14.0.ebuild [deleted file]

index d8ec9e3c430f3cff3260865bbc499641fab0e9c6..cbac55ec15d7f742a5e82bcf8b61da225f427f8a 100644 (file)
@@ -1,3 +1 @@
-DIST libinput-1.13.4.tar.xz 530000 BLAKE2B 96345625b98ecc5476b9525cac84ec6cffb5854ce8d9e197fa73dbcb3548ebfea7820fa32d4e808222c0471fc94d89003775587cc0ed9c8445dd5902d3463792 SHA512 ccfdfc704dab9ea19a503399ecd4ce3a95b8d9480b8dfddeb80be01236c34c6f2f472be0e12e04dddd68092611470d303351e092141bc7491729639bcf7e64d7
-DIST libinput-1.14.0.tar.xz 563272 BLAKE2B 9d5f831c9224b01aa4be92494f28ab95909dff2d81f5e60bada2ca12a2fb4f5745b99a4caa4abef06938cbd7d9e8da9aed85573e447ad6b6e52392e17534953a SHA512 e501c5b8a58bb287c175692af0e59ff766a8613eb576aaa0700686dfbb6c6ab63b7a5d3f148fce75397c8170bc49871068861d93c352355ab5d0d9e7f1b059ec
 DIST libinput-1.14.1.tar.xz 564412 BLAKE2B 185cede0e5d74dc27f544996aa003d50556ef50f432c73a45a1cffeac921ecc0a5c5c82158292bcd18a692d745fed552545e5ab60bcc29fb1451529cbdc7a57e SHA512 8416bab51ba1aab924fa1b41360bc2ad101fb60d3a82c73584bb1e2454554524716673e3eac7f08c18bd6a1ecdfa52ea3cfe09c7a866c59fcd47d75960e82d4c
diff --git a/dev-libs/libinput/libinput-1.13.4.ebuild b/dev-libs/libinput/libinput-1.13.4.ebuild
deleted file mode 100644 (file)
index 2a1ff84..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2014-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit meson python-any-r1 udev
-
-DESCRIPTION="Library to handle input devices in Wayland"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/10"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="doc input_devices_wacom"
-# Tests require write access to udev rules directory which is a no-no for live system.
-# Other tests are just about logs, exported symbols and autotest of the test library.
-RESTRICT="test"
-
-BDEPEND="
-       virtual/pkgconfig
-       doc? (
-               $(python_gen_any_dep '
-                       dev-python/commonmark[${PYTHON_USEDEP}]
-                       dev-python/recommonmark[${PYTHON_USEDEP}]
-                       dev-python/sphinx[${PYTHON_USEDEP}]
-                       >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
-               ')
-               >=app-doc/doxygen-1.8.3
-               >=media-gfx/graphviz-2.38.0
-       )
-"
-#      test? ( dev-util/valgrind )
-RDEPEND="
-       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
-       >=dev-libs/libevdev-1.3
-       >=sys-libs/mtdev-1.1
-       virtual/libudev:=
-       virtual/udev
-"
-DEPEND="${RDEPEND}"
-#      test? ( >=dev-libs/check-0.9.10 )
-
-python_check_deps() {
-       has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
-       has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
-       use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
-       # gui can be built but will not be installed
-       local emesonargs=(
-               -Ddebug-gui=false
-               $(meson_use doc documentation)
-               $(meson_use input_devices_wacom libwacom)
-               -Dtests=false # tests are restricted
-               -Dudev-dir="$(get_udevdir)"
-       )
-       meson_src_configure
-}
-
-src_install() {
-       meson_src_install
-       if use doc ; then
-               docinto html
-               dodoc -r "${BUILD_DIR}"/Documentation/.
-       fi
-}
-
-pkg_postinst() {
-       udevadm hwdb --update --root="${ROOT}"
-}
diff --git a/dev-libs/libinput/libinput-1.14.0.ebuild b/dev-libs/libinput/libinput-1.14.0.ebuild
deleted file mode 100644 (file)
index c6c5651..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2014-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit meson python-any-r1 udev
-
-DESCRIPTION="Library to handle input devices in Wayland"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/10"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc input_devices_wacom"
-# Tests require write access to udev rules directory which is a no-no for live system.
-# Other tests are just about logs, exported symbols and autotest of the test library.
-RESTRICT="test"
-
-BDEPEND="
-       virtual/pkgconfig
-       doc? (
-               $(python_gen_any_dep '
-                       dev-python/commonmark[${PYTHON_USEDEP}]
-                       dev-python/recommonmark[${PYTHON_USEDEP}]
-                       dev-python/sphinx[${PYTHON_USEDEP}]
-                       >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
-               ')
-               >=app-doc/doxygen-1.8.3
-               >=media-gfx/graphviz-2.38.0
-       )
-"
-#      test? ( dev-util/valgrind )
-RDEPEND="
-       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
-       >=dev-libs/libevdev-1.3
-       >=sys-libs/mtdev-1.1
-       virtual/libudev:=
-       virtual/udev
-"
-DEPEND="${RDEPEND}"
-#      test? ( >=dev-libs/check-0.9.10 )
-
-python_check_deps() {
-       has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
-       has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
-       has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
-       use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
-       # gui can be built but will not be installed
-       local emesonargs=(
-               -Ddebug-gui=false
-               $(meson_use doc documentation)
-               $(meson_use input_devices_wacom libwacom)
-               -Dtests=false # tests are restricted
-               -Dudev-dir="$(get_udevdir)"
-       )
-       meson_src_configure
-}
-
-src_install() {
-       meson_src_install
-       if use doc ; then
-               docinto html
-               dodoc -r "${BUILD_DIR}"/Documentation/.
-       fi
-}
-
-pkg_postinst() {
-       udevadm hwdb --update --root="${ROOT}"
-}