app-portage/eix: Workaround dep on protobuf-c
authorMichał Górny <mgorny@gentoo.org>
Thu, 21 May 2020 05:43:13 +0000 (07:43 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 21 May 2020 07:08:01 +0000 (09:08 +0200)
Bug: https://bugs.gentoo.org/724366
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/eix/eix-0.34.1.ebuild

index 243166afda4b8212c36955db55d4563507b5bda3..d2aaec3c2f01090fff6e7699b9dddc1d9cd89166 100644 (file)
@@ -40,6 +40,11 @@ src_prepare() {
                -i src/eix-functions.sh.in || die
        sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
                -i src/Makefile.am || die
+
+       # workaround unconditional protobuf use
+       # https://bugs.gentoo.org/724366
+       sed -e '/eix-proto\.cc/d' -i src/Makefile.am || die
+
        eautoreconf
 }