net-irc/konversation: Fix build with Qt 5.15
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 21 Apr 2020 08:38:37 +0000 (10:38 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 21 Apr 2020 09:22:16 +0000 (11:22 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch [new file with mode: 0644]
net-irc/konversation/konversation-1.7.5-r2.ebuild

diff --git a/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch b/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch
new file mode 100644 (file)
index 0000000..a17c0a4
--- /dev/null
@@ -0,0 +1,31 @@
+From f88c73cf278da9907496eab0777903f942c50cb9 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 21 Apr 2020 10:34:49 +0200
+Subject: [PATCH] Fix build with Qt 5.15 (missing header)
+
+Test Plan: Build succeeds with Qt 5.15.0_beta4
+
+Reviewers: #konversation, psn
+
+Reviewed By: #konversation, psn
+
+Differential Revision: https://phabricator.kde.org/D29038
+---
+ src/viewer/viewtree.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/viewer/viewtree.cpp b/src/viewer/viewtree.cpp
+index eeee8fb4..04ec4e54 100644
+--- a/src/viewer/viewtree.cpp
++++ b/src/viewer/viewtree.cpp
+@@ -21,6 +21,7 @@
+ #include <QFontDatabase>
+ #include <QGuiApplication>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QItemSelectionModel>
+ #include <QStyleHints>
+ #include <QToolTip>
+-- 
+2.26.1
+
index 8c3b601c6ccd0675bc6711e02f12f75fc508cb0b..22ed78f5a2d36aa5bb32d4c585035dba67e8454f 100644 (file)
@@ -65,6 +65,7 @@ PATCHES=(
        # git master
        "${FILESDIR}"/${P}-kf5bookmarks-5.69.patch
        "${FILESDIR}"/${P}-unused-kemoticons.patch
+       "${FILESDIR}"/${P}-qt-5.15.patch
 )
 
 src_configure() {