dev-util/wiggle: Use slot operators for ncurses; bump EAPI; drop old
authorJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 11:20:16 +0000 (13:20 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 16 Aug 2015 11:30:24 +0000 (13:30 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-util/wiggle/Manifest
dev-util/wiggle/wiggle-0.9-r1.ebuild [moved from dev-util/wiggle/wiggle-0.8-r1.ebuild with 68% similarity]

index 247d26d727945d18c3a2cf88266a974a19ef9978..46f673955885e18ed6f73c53bfc0dcc696de11d8 100644 (file)
@@ -1,2 +1 @@
-DIST wiggle-0.8.tar.gz 2097175 SHA256 f8bf7981f5e5811dcf6c519c5e335031a1c9b7833c919a2c5707ac8d5524b94a SHA512 536bfd8ed09decdefcba7ecf49eaa8085b9a88c163079b4a256c6796dc373f25c9947353c28f225b6c25c21b6684acbf973504838fc200e8acf746bb8e16632f WHIRLPOOL c5bc6e06079a8e856ab29e9aad4e2a36a48b618e3fb3277949eedf462668ce7afb3916d849f192cfe8bdd5d324aa7f34241c4269cb3ae5a4538f2aa0bb9fc5a6
 DIST wiggle-0.9.tar.gz 809756 SHA256 fe3dcf05a2cda07f42db2099ae8407acdb4d58bb9cfdc58c72395b7ae4a4e6b5 SHA512 2e3a4977704231f3bd6aa96ffaba8bc733acde425773b86a9649312676b44360c5b85cb48bf944cd383d8e4d0a541d88755f23be7d7a8884213f68a6320c62d9 WHIRLPOOL 95a12f73458abdb999681de7af08c407d9f7c4762c71287eb6e80e38a322459c6e1767f2bec72199cf7d8cb33912981b9fd48fbe95957f854b43e4c148c04c14
similarity index 68%
rename from dev-util/wiggle/wiggle-0.8-r1.ebuild
rename to dev-util/wiggle/wiggle-0.9-r1.ebuild
index ed270e30e970777a66bdeb81538c8e66f66e0498..acb936da89ea50296637b52a6c74fcea947c88ac 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=3
+EAPI=5
 
-inherit eutils fixheadtails toolchain-funcs
+inherit eutils fixheadtails flag-o-matic toolchain-funcs
 
 DESCRIPTION="program for applying patches that patch cannot apply because of conflicting changes"
 HOMEPAGE="http://neil.brown.name/wiggle http://neil.brown.name/git?p=wiggle"
@@ -12,13 +12,14 @@ SRC_URI="http://neil.brown.name/${PN}/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 
 # The 'p' tool does support bitkeeper, but I'm against just dumping it in here
 # due to it's size.  I've explictly listed every other dependancy here due to
 # the nature of the shell program 'p'
-RDEPEND="dev-util/diffstat
+RDEPEND="
+       dev-util/diffstat
        dev-util/patchutils
        sys-apps/diffutils
        sys-apps/findutils
@@ -27,14 +28,14 @@ RDEPEND="dev-util/diffstat
        sys-apps/less
        sys-apps/sed
        sys-apps/coreutils
-       sys-devel/patch"
+       sys-devel/patch
+       sys-libs/ncurses:5=
+       "
 DEPEND="${RDEPEND}
        sys-apps/groff
        test? ( sys-process/time )"
 
 src_prepare() {
-       epatch "${FILESDIR}/${P}-buffer-overflow.patch"
-
        # Fix the reference to the help file so `p help' works
        sed -i "s:\$0.help:${EPREFIX}/usr/share/wiggle/p.help:" p || die "sed failed on p"
 
@@ -44,18 +45,23 @@ src_prepare() {
        # Use prefixed time binary
        sed -i "s:/usr/bin/time:${EPREFIX}/usr/bin/time:" dotest || die "sed failed on dotest"
 
+       sed \
+               -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs ncurses):g" \
+               -i Makefile || die
+
        ht_fix_file p
+
+       append-cppflags -I.
 }
 
 src_compile() {
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall" \
-               wiggle || die "emake wiggle failed."
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall" ${PN}
 }
 
 src_install() {
-       dobin wiggle p || die "failed to install binaries"
-       doman wiggle.1 || die "failed to install man page"
-       dodoc ANNOUNCE INSTALL TODO DOC/diff.ps notes || die "failed to install docs"
+       dobin wiggle p
+       doman wiggle.1
+       dodoc ANNOUNCE INSTALL TODO DOC/diff.ps notes
        insinto /usr/share/wiggle
-       doins p.help || die "failed to install help file"
+       doins p.help
 }