dev-libs/leatherman: 1.12.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 30 Apr 2020 15:46:41 +0000 (10:46 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 30 Apr 2020 15:51:28 +0000 (10:51 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-libs/leatherman/Manifest
dev-libs/leatherman/leatherman-1.12.0.ebuild [new file with mode: 0644]

index 7c2b6547dd13dc0e030b9b75ece3c99f9644f5ec..ba0a675f4ed005842aaa18c0f02bc2f04776d991 100644 (file)
@@ -1,2 +1,3 @@
 DIST leatherman-1.11.0.tar.gz 815946 BLAKE2B 73afb7c517ea93d0c3dc1c88adb3e5041c764bbfb223357b14a6a3f864ff614d178e7a71293eb533f09013fe3f64d5afe40c9404882d2fe6836da7322e869d8f SHA512 0cbc558ba6976d4f14947efbc59e2ebc306a8c7e4590a22fa2e2f044b37ffd8804dbabaf96c599c47394fd9379f2de1330ce5282237b5009730d8d3b87349ae5
+DIST leatherman-1.12.0.tar.gz 815947 BLAKE2B cc268275f7ef7e9bddca9a2ca25c1a6b0bca64d57f90a485b83103a2477d476a39fe91ccf46798f1885b29c697de6556890131c7aac2a9e61590edab66fd6ea7 SHA512 2ceb16f94bf3d06bfe477a40e15db5a1d3d3999eaa7023245a08ab4e0054179f28308d9bf6ba73a839ca3a68130259894593fc8e77664b672ac5f3d20511a4d2
 DIST leatherman-1.3.0.tar.gz 434229 BLAKE2B e0c19bca2378afc4928554ac0862543504ba725aadc6cffd78220f7f7f1b725cad960fc6d9fdd2d54a43c233b35959ebcb9c71d1191a5535703599fa32e3301e SHA512 5e06be7add652f69b0d4a8d778e33dfb68183c4d598217cc6542d2431f7984f0af989c27bd69e89b77ab03d6dd2adab9d70f68cd87dae20d8e24ae05923fbe9b
diff --git a/dev-libs/leatherman/leatherman-1.12.0.ebuild b/dev-libs/leatherman/leatherman-1.12.0.ebuild
new file mode 100644 (file)
index 0000000..aef4cd9
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54:=[nls]
+       net-misc/curl
+       >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+       sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_VERBOSE_MAKEFILE=ON
+               -DCMAKE_BUILD_TYPE=None
+       )
+       if ! use static-libs; then
+               mycmakeargs+=(
+                       -DLEATHERMAN_SHARED=ON
+               )
+       else
+               mycmakeargs+=(
+                       -DLEATHERMAN_SHARED=OFF
+               )
+       fi
+       if use debug; then
+               mycmakeargs+=(
+                 -DCMAKE_BUILD_TYPE=Debug
+               )
+       fi
+       cmake-utils_src_configure
+}
+
+src_test() {
+       "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+       cmake-utils_src_install
+}