Version bump, bug 166653, ebuild cleanup
authorSteve Dibb <beandog@gentoo.org>
Sun, 25 Feb 2007 16:07:20 +0000 (16:07 +0000)
committerSteve Dibb <beandog@gentoo.org>
Sun, 25 Feb 2007 16:07:20 +0000 (16:07 +0000)
Package-Manager: portage-2.1.1-r2

media-video/tovid/ChangeLog
media-video/tovid/files/digest-tovid-0.29-r1 [new file with mode: 0644]
media-video/tovid/files/digest-tovid-0.30 [new file with mode: 0644]
media-video/tovid/files/tovid-0.30-configure.patch [new file with mode: 0644]
media-video/tovid/tovid-0.29-r1.ebuild [new file with mode: 0644]
media-video/tovid/tovid-0.30.ebuild [new file with mode: 0644]

index 529a45eaa44ffa029ef518141f3e5f2f41f5c9b5..045db4f56eb6ae91cfb9f9918f01325ea70fdf5b 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for media-video/tovid
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.5 2007/01/01 17:10:50 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.6 2007/02/25 16:07:20 beandog Exp $
+
+*tovid-0.30 (25 Feb 2007)
+*tovid-0.29-r1 (25 Feb 2007)
+
+  25 Feb 2007; Steve Dibb <beandog@gentoo.org>
+  +files/tovid-0.30-configure.patch, -tovid-0.29.ebuild,
+  +tovid-0.29-r1.ebuild, +tovid-0.30.ebuild:
+  Version bump, bug 166653, ebuild cleanup
 
   01 Jan 2007; Steve Dibb <beandog@gentoo.org> tovid-0.28.ebuild,
   tovid-0.28-r1.ebuild, tovid-0.29.ebuild:
diff --git a/media-video/tovid/files/digest-tovid-0.29-r1 b/media-video/tovid/files/digest-tovid-0.29-r1
new file mode 100644 (file)
index 0000000..378a8d8
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 46b5d0d227ac651b086b8ae8d2e3969b tovid-0.29.tar.gz 345846
+RMD160 612d24af62e97031cff4c767865ec64452ae750f tovid-0.29.tar.gz 345846
+SHA256 891ab7f3acccde7f3c440630de6d5c6deab2e002311351101d7da8e6dd542606 tovid-0.29.tar.gz 345846
diff --git a/media-video/tovid/files/digest-tovid-0.30 b/media-video/tovid/files/digest-tovid-0.30
new file mode 100644 (file)
index 0000000..536aabe
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 feb3418acade9584cd8256f5ce2efb88 tovid-0.30.tar.gz 393084
+RMD160 ef7e35e6553fddc4f601fd44b681b5afd643705a tovid-0.30.tar.gz 393084
+SHA256 fe30a4ef08d1aa15fcb811d123d14a7934a9f5180abbcaddafef1e543c42720f tovid-0.30.tar.gz 393084
diff --git a/media-video/tovid/files/tovid-0.30-configure.patch b/media-video/tovid/files/tovid-0.30-configure.patch
new file mode 100644 (file)
index 0000000..306218f
--- /dev/null
@@ -0,0 +1,11 @@
+--- configure   2007-02-13 03:16:02.000000000 +0100
++++ configure.new       2007-02-15 12:34:20.000000000 +0100
+@@ -2392,9 +2392,9 @@
+-  PYTHON_PREFIX='${prefix}'
++  PYTHON_PREFIX='/usr'
+-  PYTHON_EXEC_PREFIX='${exec_prefix}'
++  PYTHON_EXEC_PREFIX='/usr'
diff --git a/media-video/tovid/tovid-0.29-r1.ebuild b/media-video/tovid/tovid-0.29-r1.ebuild
new file mode 100644 (file)
index 0000000..06f2f32
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/tovid-0.29-r1.ebuild,v 1.1 2007/02/25 16:07:20 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="Video conversion and DVD authoring tools"
+HOMEPAGE="http://tovid.wikia.com/"
+SRC_URI="mirror://sourceforge/tovid/${P}.tar.gz"
+IUSE=""
+DEPEND="media-video/mplayer"
+RDEPEND="media-video/mjpegtools
+       media-video/ffmpeg
+       media-video/transcode
+       media-sound/normalize
+       media-gfx/imagemagick
+       media-sound/sox
+       media-video/dvdauthor
+       media-video/vcdimager
+       media-video/lsdvd
+       virtual/cdrtools
+       dev-python/pycairo
+       >=dev-python/wxpython-2.6
+       app-cdr/dvd+rw-tools
+       app-cdr/cdrdao
+       dev-python/imaging"
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+SLOT="0"
+
+pkg_setup() {
+       if ! built_with_use media-video/mplayer encode; then
+               eerror "Please emerge media-video/mplayer with useflag 'encode'."
+               die "Fix USE flags and re-emerge"
+       fi
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install died"
+       dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+       einfo ""
+       einfo "List of suite components:"
+       einfo "   idvid:       Identifies video format, resolution, and length"
+       einfo "   makemenu:    Creates (S)VCD/DVD menus"
+       einfo "   makeslides:  Creates mpeg still slides for (S)VCD"
+       einfo "   makexml:     Creates XML specification for an (S)VCD or DVD navigation hierarchy"
+       einfo "   makedvd:     Creates the DVD structure and/or iso image"
+       einfo "   postproc:    Adjusts A/V sync and does shrinking of encoded video"
+       einfo "   tovid:       Converts video to (S)VCD or DVD mpeg format"
+       einfo "   tovidgui:    The tovid GUI"
+       einfo "   pytovid:     The new (experimental) python based tovid script"
+       einfo "   todisc:      Create a DVD with animated menus"
+       einfo "   todiscgui:   Experimental gui for todisc"
+       einfo ""
+       einfo "Please check out the tovid documentation on the web:"
+       einfo "   http://tovid.wikia.com/"
+       einfo ""
+}
diff --git a/media-video/tovid/tovid-0.30.ebuild b/media-video/tovid/tovid-0.30.ebuild
new file mode 100644 (file)
index 0000000..76f56db
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/tovid-0.30.ebuild,v 1.1 2007/02/25 16:07:20 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="Video conversion and DVD authoring tools"
+HOMEPAGE="http://tovid.wikia.com/"
+SRC_URI="mirror://sourceforge/tovid/${P}.tar.gz"
+IUSE=""
+DEPEND="media-video/mplayer
+       app-text/txt2tags"
+RDEPEND="media-video/mjpegtools
+       media-video/ffmpeg
+       media-video/transcode
+       media-sound/normalize
+       media-gfx/imagemagick
+       media-sound/sox
+       media-video/dvdauthor
+       media-video/vcdimager
+       media-video/lsdvd
+       virtual/cdrtools
+       dev-python/pycairo
+       >=dev-python/wxpython-2.6
+       app-cdr/dvd+rw-tools
+       app-cdr/cdrdao
+       dev-python/imaging"
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+SLOT="0"
+
+pkg_setup() {
+       if ! built_with_use media-video/mplayer encode; then
+               eerror "Please emerge media-video/mplayer with useflag 'encode'."
+               die "Fix USE flags and re-emerge"
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${P}-configure.patch"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install died"
+       dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+       einfo ""
+       einfo "List of suite components:"
+       einfo "   idvid:       Identifies video format, resolution, and length"
+       einfo "   makemenu:    Creates (S)VCD/DVD menus"
+       einfo "   makeslides:  Creates mpeg still slides for (S)VCD"
+       einfo "   makexml:     Creates XML specification for an (S)VCD or DVD navigation hierarchy"
+       einfo "   makedvd:     Creates the DVD structure and/or iso image"
+       einfo "   postproc:    Adjusts A/V sync and does shrinking of encoded video"
+       einfo "   tovid:       Converts video to (S)VCD or DVD mpeg format"
+       einfo "   tovidgui:    The tovid GUI"
+       einfo "   pytovid:     The new (experimental) python based tovid script"
+       einfo "   todisc:      Create a DVD with animated menus"
+       einfo "   todiscgui:   Experimental gui for todisc"
+       einfo ""
+       einfo "Please check out the tovid documentation on the web:"
+       einfo "   http://tovid.wikia.com/"
+       einfo ""
+}