Copied ebuild from vdr-testing overlay. Now enable software-OSD-Blending mode as...
authorMatthias Schwarzott <zzam@gentoo.org>
Tue, 14 Nov 2006 09:27:13 +0000 (09:27 +0000)
committerMatthias Schwarzott <zzam@gentoo.org>
Tue, 14 Nov 2006 09:27:13 +0000 (09:27 +0000)
Package-Manager: portage-2.1.2_rc1-r6

media-plugins/vdr-softdevice/ChangeLog
media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1-r1 [new file with mode: 0644]
media-plugins/vdr-softdevice/files/vdr-softdevice-0.3.1-osdmode-software-default.diff [new file with mode: 0644]
media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r1.ebuild [new file with mode: 0644]

index d926dbc367dca7435b95136e138c4f68491c2082..c144959e4d05ecc95ceb6e770934d31ef14abd1a 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for media-plugins/vdr-softdevice
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.27 2006/11/14 09:19:17 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/ChangeLog,v 1.28 2006/11/14 09:27:13 zzam Exp $
+
+*vdr-softdevice-0.3.1-r1 (14 Nov 2006)
+
+  14 Nov 2006; Matthias Schwarzott <zzam@gentoo.org>
+  +files/vdr-softdevice-0.3.1-osdmode-software-default.diff,
+  -vdr-softdevice-0.3.1.ebuild, +vdr-softdevice-0.3.1-r1.ebuild:
+  Copied ebuild from vdr-testing overlay. Now enable software-OSD-Blending
+  mode as default.
 
   13 Nov 2006; Matthias Schwarzott <zzam@gentoo.org>
   vdr-softdevice-0.3.0-r1.ebuild:
diff --git a/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1-r1 b/media-plugins/vdr-softdevice/files/digest-vdr-softdevice-0.3.1-r1
new file mode 100644 (file)
index 0000000..bdd142b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 269777294df93a027ac9dc849af0edb2 vdr-softdevice-0.3.1.tgz 154509
+RMD160 b582215eca1c0ce954eca54045456145488b1b34 vdr-softdevice-0.3.1.tgz 154509
+SHA256 d88fc234ad6d3686b95d4848519ffdb97ee22a1fcd8cff60d737c0ecb1a43252 vdr-softdevice-0.3.1.tgz 154509
diff --git a/media-plugins/vdr-softdevice/files/vdr-softdevice-0.3.1-osdmode-software-default.diff b/media-plugins/vdr-softdevice/files/vdr-softdevice-0.3.1-osdmode-software-default.diff
new file mode 100644 (file)
index 0000000..45503a0
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ru softdevice-0.3.1-orig/setup-softdevice.c softdevice-0.3.1/setup-softdevice.c
+--- softdevice-0.3.1-orig/setup-softdevice.c   2006-11-09 14:43:21.841179646 +0100
++++ softdevice-0.3.1/setup-softdevice.c        2006-11-09 14:43:28.846888627 +0100
+@@ -123,6 +123,7 @@
+   syncTimerMode = 2;
+   vidCaps = 0;
+   vidBrightness = vidHue = vidContrast = vidSaturation = -1;
++  osdMode = 1;
+   /* --------------------------------------------------------------------------
+    * these screen width/height values are operating in square pixel mode.
diff --git a/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r1.ebuild b/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r1.ebuild
new file mode 100644 (file)
index 0000000..760ce53
--- /dev/null
@@ -0,0 +1,133 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-softdevice/vdr-softdevice-0.3.1-r1.ebuild,v 1.1 2006/11/14 09:27:13 zzam Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: Software output-Device"
+HOMEPAGE="http://softdevice.berlios.de/"
+SRC_URI="mirror://gentoo/${P}.tgz
+               http://dev.gentoo.org/~zzam/distfiles/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="xv fbcon directfb mmx mmxext xinerama"
+
+RDEPEND=">=media-video/vdr-1.3.36
+       >=media-video/ffmpeg-0.4.9_pre1
+       directfb? (
+               dev-libs/DirectFB
+               dev-libs/DFB++
+       )
+       media-libs/alsa-lib
+       xv? ( || ( ( x11-libs/libX11
+                               x11-libs/libXext
+                               x11-libs/libXi
+                               x11-libs/libXv
+                               xinerama? ( x11-libs/libXinerama )
+                       )
+                       virtual/x11
+               ) )"
+
+DEPEND="${RDEPEND}
+       xv? ( || ( ( x11-proto/xproto
+                               x11-proto/xextproto
+                               x11-libs/libXv
+                               xinerama? ( x11-proto/xineramaproto )
+                       )
+                       virtual/x11
+       ) )
+       fbcon? ( sys-kernel/linux-headers )
+       dev-util/pkgconfig"
+
+
+PATCHES="
+               ${FILESDIR}/vdr-softdevice-0.2.3-shm-fullscreen.diff
+               ${FILESDIR}/softdevice-cvs-xinerama-configure-opts.patch
+               ${FILESDIR}/vdr-softdevice-0.3.1-osdmode-software-default.diff"
+
+pkg_setup() {
+       vdr-plugin_pkg_setup
+
+       if use !xv && use !fbcon && use !directfb; then
+               ewarn "You need to set at least one of these use-flags: xv fbcon directfb"
+               die "no output-method enabled"
+       fi
+
+       COMPILE_SHM=0
+       if has_version ">=media-video/vdr-1.3.0"; then
+               if use xv; then
+                       COMPILE_SHM=1
+               else
+                       einfo "SHM does only support xv at the moment"
+               fi
+       else
+               einfo "SHM not supported on vdr-1.2"
+       fi
+       case ${COMPILE_SHM} in
+               0)      einfo "SHM support will not be compiled." ;;
+               1)      einfo "SHM support will be compiled." ;;
+       esac
+
+       # Check for ffmpeg relying on libtheora without pkg-config-file
+       # Bug #142250
+       if built_with_use media-video/ffmpeg theora     && \
+               has_version "<media-libs/libtheora/libtheora-1.0_alpha4"; then
+
+                       eerror "This package will not work when using ffmpeg with"
+                       eerror "USE=\"theora\" combined with media-libs/libtheora"
+                       eerror "older than version 1.0_alpha4."
+                       eerror "Please update to at least media-libs/libtheora-1.0_alpha4."
+                       die "Please update to at least media-libs/libtheora-1.0_alpha4."
+       fi
+}
+
+src_compile() {
+       local MYOPTS=""
+       MYOPTS="${MYOPTS} --disable-vidix"
+       use xv || MYOPTS="${MYOPTS} --disable-xv"
+       use fbcon || MYOPTS="${MYOPTS} --disable-fb"
+       use directfb || MYOPTS="${MYOPTS} --disable-dfb"
+
+       # MMX-Support
+       # hardcode mmx for amd64 - do not disable even without use-flag
+       if ! use amd64; then
+               use mmx || MYOPTS="${MYOPTS} --disable-mmx"
+               use mmxext || MYOPTS="${MYOPTS} --disable-mmx2"
+
+               if use !mmx && use !mmxext; then
+                       ewarn "${PN}"' does not compile with USE="-mmx -mmxext".'
+                       ewarn 'Please enable at least one of these two use-flags.'
+                       die "${PN}"' does not compile with USE="-mmx -mmxext".'
+               fi
+       fi
+
+       use xinerama || MYOPTS="${MYOPTS} --disable-xinerama"
+
+       [[ ${COMPILE_SHM} == 1 ]] || MYOPTS="${MYOPTS} --disable-shm"
+
+       cd ${S}
+       einfo configure ${MYOPTS}
+       ./configure ${MYOPTS} || die "configure failed"
+
+       vdr-plugin_src_compile
+}
+
+src_install() {
+       vdr-plugin_src_install
+
+       cd ${S}
+
+       insinto "${VDR_PLUGIN_DIR}"
+       doins libsoftdevice-*.so.*
+
+       if [[ "${COMPILE_SHM}" = "1" ]]; then
+               exeinto "/usr/bin"
+               doexe ShmClient
+       fi
+
+       insinto /usr/include/vdr-softdevice
+       doins *.h
+}
+