sys-libs/libosinfo: bump to 1.6.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 17:46:54 +0000 (19:46 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 18:09:36 +0000 (20:09 +0200)
There's a 1.7.1 out, but we were so behind that this is just a quick
bump to move us forward, with the meson port in 1.7 to be done later
with more effort.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
sys-libs/libosinfo/Manifest
sys-libs/libosinfo/libosinfo-1.6.0.ebuild [new file with mode: 0644]

index ab0943ecc2d294f367a3dd344136da18133aeaf1..53b0d226d06ccd4bcb25cc86690c269f5f9302db 100644 (file)
@@ -1 +1,2 @@
 DIST libosinfo-1.4.0.tar.gz 1075852 BLAKE2B 93129a29ea3a1a3aa69fdceabcf6f41393c8e1dd3f92872d97dcc23a3316b0e4d16ede104da9a3ea0c49d352ba88e05ba5a38806c8c039fe92217e4b6e3140ab SHA512 531b7acf811add53252e52917f8b13b409dbe7a4bc5837dcbe34e729b0f294e760d5a57c5c1c56f1f65217b7fc6e285a56a6fa49d36f02cf696b7cc181db1fe5
+DIST libosinfo-1.6.0.tar.gz 1024787 BLAKE2B 4d0783b41f8c9ed7472c798acede0cd1f3808858ab954e838e8d7543dc50a9819d1f26b0cb02a97c8ed8ebee47db1b915aab5daadc0be2742e8f5c1ba8451a75 SHA512 53359095e40ef12e0cc142ddc92119b4a753bb47a728f13a8ff500a19108a44eb1f6ebe4ed67b04347a707dd0c0d55bcfe6815b57d187237dddd7376ebe9cf5e
diff --git a/sys-libs/libosinfo/libosinfo-1.6.0.ebuild b/sys-libs/libosinfo/libosinfo-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..1990a9c
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 udev vala
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+IUSE="+introspection +vala test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Unsure about osinfo-db-tools rdep, but at least fedora does it too
+RDEPEND="
+       >=dev-libs/glib-2.44:2
+       >=dev-libs/libxml2-2.6.0
+       >=dev-libs/libxslt-1.0.0
+       net-libs/libsoup:2.4
+       sys-apps/hwids[pci,usb]
+       sys-apps/osinfo-db-tools
+       sys-apps/osinfo-db
+       introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+# perl dep is for pod2man, and configure.ac checks for it too now
+DEPEND="${RDEPEND}
+       dev-lang/perl
+       dev-libs/gobject-introspection-common
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.10
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+       gnome2_src_prepare
+       use vala && vala_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --with-usb-ids-path=/usr/share/misc/usb.ids \
+               --with-pci-ids-path=/usr/share/misc/pci.ids \
+               --disable-static \
+               $(use_enable test tests) \
+               $(use_enable introspection) \
+               $(use_enable vala) \
+               --disable-coverage
+}