media-libs/libepoxy: python3_8 support, minor cleanup
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 15:50:39 +0000 (17:50 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 15:56:39 +0000 (17:56 +0200)
Tests passed.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/libepoxy/libepoxy-1.5.4.ebuild
media-libs/libepoxy/libepoxy-9999.ebuild

index 02f1bc297cf59d91f042a4c617ec870ba6f213d5..889f03836415d4d25f4af06e02b18a1287129ae8 100644 (file)
@@ -3,41 +3,34 @@
 
 EAPI=7
 
-EGIT_REPO_URI="https://github.com/anholt/${PN}.git"
-
-if [[ ${PV} = 9999* ]]; then
-       GIT_ECLASS="git-r3"
-fi
-
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE='xml(+)'
-inherit ${GIT_ECLASS} meson multilib-minimal python-any-r1
+inherit meson multilib-minimal python-any-r1
 
-DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
-HOMEPAGE="https://github.com/anholt/libepoxy"
 if [[ ${PV} = 9999* ]]; then
-       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/anholt/${PN}.git"
+       inherit git-r3
 else
-       KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
        SRC_URI="https://github.com/anholt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
 fi
 
+DESCRIPTION="Library for handling OpenGL function pointer management"
+HOMEPAGE="https://github.com/anholt/libepoxy"
+
 LICENSE="MIT"
 SLOT="0"
-RESTRICT="!test? ( test )"
 IUSE="+egl test +X"
 
-RDEPEND="egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )"
-DEPEND="X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
-       ${RDEPEND}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )"
 BDEPEND="${PYTHON_DEPS}
        virtual/pkgconfig"
 
-src_unpack() {
-       default
-       [[ $PV = 9999* ]] && git-r3_src_unpack
-}
-
 multilib_src_configure() {
        local emesonargs=(
                -Degl=$(usex egl)
index 7d68a7cdbcf2fff0e30b10406d8624121ca8888b..17b8095b0f30fc680d9b0d1d24b167ad4b564793 100644 (file)
@@ -3,41 +3,34 @@
 
 EAPI=7
 
-EGIT_REPO_URI="https://github.com/anholt/${PN}.git"
-
-if [[ ${PV} = 9999* ]]; then
-       GIT_ECLASS="git-r3"
-fi
-
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE='xml(+)'
-inherit ${GIT_ECLASS} meson multilib-minimal python-any-r1
+inherit meson multilib-minimal python-any-r1
 
-DESCRIPTION="Epoxy is a library for handling OpenGL function pointer management for you"
-HOMEPAGE="https://github.com/anholt/libepoxy"
 if [[ ${PV} = 9999* ]]; then
-       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/anholt/${PN}.git"
+       inherit git-r3
 else
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
        SRC_URI="https://github.com/anholt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
 fi
 
+DESCRIPTION="Library for handling OpenGL function pointer management"
+HOMEPAGE="https://github.com/anholt/libepoxy"
+
 LICENSE="MIT"
 SLOT="0"
-RESTRICT="!test? ( test )"
 IUSE="+egl test +X"
 
-RDEPEND="egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )"
-DEPEND="X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
-       ${RDEPEND}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       egl? ( media-libs/mesa[egl,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )"
 BDEPEND="${PYTHON_DEPS}
        virtual/pkgconfig"
 
-src_unpack() {
-       default
-       [[ $PV = 9999* ]] && git-r3_src_unpack
-}
-
 multilib_src_configure() {
        local emesonargs=(
                -Degl=$(usex egl)