sys-apps/pcsc-tools: Version bump (v1.5.6)
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 16 Mar 2020 07:19:43 +0000 (10:19 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 16 Mar 2020 07:19:43 +0000 (10:19 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sys-apps/pcsc-tools/Manifest
sys-apps/pcsc-tools/pcsc-tools-1.5.6.ebuild [new file with mode: 0644]

index 0f5fa654df9069707ed713e2b4a01af0f2123347..c74d6bf755ebb0a42f34f79eb3a807b06a219c86 100644 (file)
@@ -1,2 +1,3 @@
 DIST pcsc-tools-1.5.3.tar.bz2 267564 BLAKE2B b060e6fc923c6274d38c364325c367f793acf2979f2410c92857cce7483ebbb59db07657bc27be6d5a799f7f85da45782c4f1a9bbf7c450b43d533dce54755e7 SHA512 da5b362b7a3a6d47dd309ff217e6dd8af29298501db5e898ecd68762020ce62fc982132205f9bbee159a7d7eac549fdb8f25395416bb52bc0d0c888a5b0fa1a0
 DIST pcsc-tools-1.5.5.tar.bz2 287752 BLAKE2B dd0563f75c2b1cd05f21916287ff98c8b5f0c444b71ac7cda4da3a9dbf2db58f92555d54029a73feffd651b42ccae820670df1a90c8541eab188bf66b51ad114 SHA512 b34eaea663274e03790e409909ddb9819b20882795af2618068f59532e2f79973b22b4d0c468a0bb4338c74d1ceca310e8c60005fb1d15ab4f34053125ece3bf
+DIST pcsc-tools-1.5.6.tar.bz2 289691 BLAKE2B 35dd50a3a8babff89f9e5d769ef70a573e58b2780d680c82dfa07177a3daaf527b5ccca665c901f9667ca4a81719916bd5aebb2e9b1b4d0301001498fe587832 SHA512 94076ed5af698afcec05da9645d7108c02c110fd0ee5efecbd8e0c7eb5ed9a55ee857d23b79ab2ccb93847f8a36f996fa9d521d999395f63274d4bf1d9cf3d26
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.6.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.6.ebuild
new file mode 100644 (file)
index 0000000..aae8a02
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="${DEPEND}
+       dev-perl/pcsc-perl
+       gtk? ( dev-perl/Gtk2 )"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+       README Changelog
+)
+
+src_compile() {
+       # explicitly only build the pcsc_scan application, or the man
+       # pages will be gzipped first, and then unpacked.
+       emake pcsc_scan CC=$(tc-getCC)
+}
+
+src_install() {
+       einstalldocs
+
+       # install manually, makes it much easier since the Makefile
+       # requires fiddling with
+       dobin ATR_analysis scriptor pcsc_scan
+       doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+       if use gtk; then
+               domenu gscriptor.desktop
+               dobin gscriptor
+               doman gscriptor.1p
+       fi
+
+       if use network-cron ; then
+               exeinto /etc/cron.monthly
+               newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+       fi
+
+       insinto /usr/share/pcsc
+       doins smartcard_list.txt
+}
+
+pkg_postinst() {
+       use gtk && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}