dev-libs/rocr-runtime: add -9999 version
authorCraig Andrews <candrews@gentoo.org>
Wed, 24 Jul 2019 18:48:47 +0000 (14:48 -0400)
committerCraig Andrews <candrews@gentoo.org>
Wed, 7 Aug 2019 17:38:45 +0000 (13:38 -0400)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-libs/rocr-runtime/rocr-runtime-9999.ebuild [new file with mode: 0644]

diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
new file mode 100644 (file)
index 0000000..a311933
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+       inherit git-r3
+       S="${WORKDIR}/${P}/src"
+else
+       SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/ROCR-Runtime-roc-${PV}/src"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl"
+DEPEND="${RDEPEND}
+       dev-libs/roct-thunk-interface"
+
+src_prepare() {
+       sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+       cmake-utils_src_prepare
+}