sci-visualization/gnuplot: Fix build of documentation without gd.
authorUlrich Müller <ulm@gentoo.org>
Tue, 16 Jul 2019 09:07:38 +0000 (11:07 +0200)
committerUlrich Müller <ulm@gentoo.org>
Tue, 16 Jul 2019 09:08:12 +0000 (11:08 +0200)
Bug: https://bugs.gentoo.org/577828
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
sci-visualization/gnuplot/gnuplot-5.0.7.ebuild
sci-visualization/gnuplot/gnuplot-5.2.6.ebuild
sci-visualization/gnuplot/gnuplot-5.2.7.ebuild
sci-visualization/gnuplot/gnuplot-5.2.9999.ebuild

index 8d3338bad0a1b18cf6a3b401b03f3f0f15c44554..27def81ca7fe297569192be3e0366e6c56026880 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -160,10 +160,10 @@ src_compile() {
        if use doc; then
                # Avoid sandbox violation in epstopdf/ghostscript
                addpredict /var/cache/fontconfig
-               if use cairo; then
+               if use cairo && use gd; then
                        emake -C docs pdf
                else
-                       ewarn "Cannot build figures unless cairo is enabled."
+                       ewarn "Cannot build figures unless cairo and gd are enabled."
                        ewarn "Building documentation without figures."
                        emake -C docs pdf_nofig
                        mv docs/nofigures.pdf docs/gnuplot.pdf || die
index e71b7253da9e7b619ad033915d39c6e27d05bd3a..99a845fc74334cfc6640fb6e4abc86a2b0937bce 100644 (file)
@@ -158,10 +158,10 @@ src_compile() {
        if use doc; then
                # Avoid sandbox violation in epstopdf/ghostscript
                addpredict /var/cache/fontconfig
-               if use cairo; then
+               if use cairo && use gd; then
                        emake -C docs pdf
                else
-                       ewarn "Cannot build figures unless cairo is enabled."
+                       ewarn "Cannot build figures unless cairo and gd are enabled."
                        ewarn "Building documentation without figures."
                        emake -C docs pdf_nofig
                        mv docs/nofigures.pdf docs/gnuplot.pdf || die
index 9240510b10326bd8710270bf976ade1825487742..4ea9c17d14429b9aa0ab9519ea2d85796b08541a 100644 (file)
@@ -158,10 +158,10 @@ src_compile() {
        if use doc; then
                # Avoid sandbox violation in epstopdf/ghostscript
                addpredict /var/cache/fontconfig
-               if use cairo; then
+               if use cairo && use gd; then
                        emake -C docs pdf
                else
-                       ewarn "Cannot build figures unless cairo is enabled."
+                       ewarn "Cannot build figures unless cairo and gd are enabled."
                        ewarn "Building documentation without figures."
                        emake -C docs pdf_nofig
                        mv docs/nofigures.pdf docs/gnuplot.pdf || die
index 517402b50184a9b247276272ac9488eaf055216d..38d6d67f756b7ddf11c7beb9522b42168c6f6243 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -156,10 +156,10 @@ src_compile() {
        if use doc; then
                # Avoid sandbox violation in epstopdf/ghostscript
                addpredict /var/cache/fontconfig
-               if use cairo; then
+               if use cairo && use gd; then
                        emake -C docs pdf
                else
-                       ewarn "Cannot build figures unless cairo is enabled."
+                       ewarn "Cannot build figures unless cairo and gd are enabled."
                        ewarn "Building documentation without figures."
                        emake -C docs pdf_nofig
                        mv docs/nofigures.pdf docs/gnuplot.pdf || die