media-sound/cdparanoia: Fix missing musl includes
authorPacho Ramos <pacho@gentoo.org>
Sun, 3 May 2020 09:27:50 +0000 (11:27 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 3 May 2020 09:49:06 +0000 (11:49 +0200)
Thanks-to: Toralf Förster
Thanks-to: Michael 'veremitz' Everitt
Closes: https://bugs.gentoo.org/713740
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
media-sound/cdparanoia/cdparanoia-3.10.2-r7.ebuild
media-sound/cdparanoia/files/cdparanoia-missing-sys_types_h.patch [new file with mode: 0644]

index 38d07ee8cf0fc5c93effc6ce869600311491ce43..afbbe92e3f8d741d8b9e2c6e5517d89b021f2b7a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -27,6 +27,8 @@ src_prepare() {
        # Patches from previus patchset + Fedora + Debian
        eapply "${WORKDIR}"/patches/*.patch
 
+       eapply "${FILESDIR}"/${PN}-missing-sys_types_h.patch #713740
+
        mv configure.guess config.guess
        mv configure.sub config.sub
 
diff --git a/media-sound/cdparanoia/files/cdparanoia-missing-sys_types_h.patch b/media-sound/cdparanoia/files/cdparanoia-missing-sys_types_h.patch
new file mode 100644 (file)
index 0000000..010ed4a
--- /dev/null
@@ -0,0 +1,24 @@
+diff -Naur cdparanoia-III-10.2.orig/interface/utils.h cdparanoia-III-10.2/interface/utils.h
+--- cdparanoia-III-10.2.orig/interface/utils.h 2008-08-14 06:56:20.000000000 -0700
++++ cdparanoia-III-10.2/interface/utils.h      2016-05-30 14:35:57.071615252 -0700
+@@ -3,6 +3,8 @@
+ #include <errno.h>
+ #include <string.h>
++#include <sys/types.h>
++
+ /* I wonder how many alignment issues this is gonna trip in the
+    future...  it shouldn't trip any...  I guess we'll find out :) */
+diff -Naur cdparanoia-III-10.2.orig/utils.h cdparanoia-III-10.2/utils.h
+--- cdparanoia-III-10.2.orig/utils.h   2008-08-22 02:39:06.000000000 -0700
++++ cdparanoia-III-10.2/utils.h        2016-05-30 14:35:33.101409747 -0700
+@@ -4,6 +4,8 @@
+ #include <errno.h>
+ #include <string.h>
++#include <sys/types.h>
++
+ extern long buffering_write(int outf, char *buffer, long num);
+ extern int buffering_close(int fd);