app-text/html401: Restore .cat backup for non-empty too
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 07:07:36 +0000 (09:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 07:11:54 +0000 (09:11 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-text/html401/html401-19991224-r4.ebuild

index 8f75a577ac4d1751c220aff6ca080049c7b9a370..2456ff58ee72917866beaf46e4d2aba5896c709c 100644 (file)
@@ -36,8 +36,10 @@ pkg_preinst() {
 }
 
 pkg_postinst() {
-       if [[ ! -f ${EROOT}/etc/sgml/html401.cat ]]; then
-               cp "${T}"/html401.cat "${EROOT}"/etc/sgml/ || die
+       local backup=${T}/html401.cat
+       local real=${EROOT}/etc/sgml/html401.cat
+       if ! cmp -s "${backup}" "${real}"; then
+               cp "${backup}" "${real}" || die
        fi
        sgml-catalog-r1_pkg_postinst
 }