sys-cluster/cinder: Drop python2_7
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Dec 2019 16:55:46 +0000 (17:55 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 29 Dec 2019 13:22:56 +0000 (14:22 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-cluster/cinder/cinder-13.0.7.ebuild
sys-cluster/cinder/cinder-14.0.1.ebuild
sys-cluster/cinder/cinder-15.0.0.ebuild
sys-cluster/cinder/cinder-2018.2.9999.ebuild
sys-cluster/cinder/cinder-2019.1.9999.ebuild
sys-cluster/cinder/cinder-2019.2.9999.ebuild

index 4c8eb939d671138f6a77fa1ac6f660243c394774..54947395723c50e9cac1b3c456d5a5721d581226 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
 
+PYTHON_COMPAT=( python3_{5,6} )
 inherit distutils-r1 eutils linux-info user
 
 DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -38,7 +38,6 @@ RDEPEND="
        !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        >=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
-       dev-python/enum34[$(python_gen_usedep 'python2_7')]
        >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
        >=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
index fda10c62776664a2f232facf62baa8b524258286..13f95db99b4cb56b3136ccc2353687f54d29f773 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info user
 
 DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,7 +36,6 @@ RDEPEND="
        ${CDEPEND}
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        >=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
-       dev-python/enum34[$(python_gen_usedep 'python2_7')]
        >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
        >=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
index 1debd3eab15e0e91c2bd378f89aef23eeec0f8ff..6b69bfb292a19e82b7fed7ccdd4e617bc15a50c8 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info user
 
 DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,7 +36,6 @@ RDEPEND="
        ${CDEPEND}
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        >=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2_7')
        >=dev-python/eventlet-0.22.0[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
index 23e3164d865862a189da665d050f6939a6652dc4..8629b837e15d082c0b6c5eea7f131e4cf8c09e60 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
 
+PYTHON_COMPAT=( python3_{5,6} )
 inherit distutils-r1 eutils linux-info user
 
 DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -38,7 +38,6 @@ RDEPEND="
        !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        >=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
-       dev-python/enum34[$(python_gen_usedep 'python2_7')]
        >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
        >=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
index bf4f9da51b436a89ef7bbc1484794f96c2d4d869..d741fd9132cca561f9f4ec60edeab26dc6ab875c 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info user
 
 DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,7 +36,6 @@ RDEPEND="
        ${CDEPEND}
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        >=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
-       dev-python/enum34[$(python_gen_usedep 'python2_7')]
        >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
        >=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
index e9c432edc27289e0fc7d466d8d9b35e25df09012..09e2c94c85a8e3d5bafc6280d10f75fdd43b730b 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
+PYTHON_COMPAT=( python3_{5,6,7} )
 inherit distutils-r1 eutils linux-info user
 
 DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,8 +36,6 @@ RDEPEND="
        ${CDEPEND}
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        >=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
-       dev-python/enum34[$(python_gen_usedep 'python2_7')]
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2_7')
        >=dev-python/eventlet-0.22.0[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
        !~dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]