dev-python/jaraco-functools: bump to 1.15.1
authorLouis Sautier <sautier.louis@gmail.com>
Sun, 18 Sep 2016 01:21:50 +0000 (03:21 +0200)
committerGöktürk Yüksek <gokturk@gentoo.org>
Wed, 21 Sep 2016 03:44:04 +0000 (23:44 -0400)
Package-Manager: portage-2.3.0

dev-python/jaraco-functools/Manifest
dev-python/jaraco-functools/jaraco-functools-1.15.1.ebuild [new file with mode: 0644]

index 28c70bb84f2842150532f95ff1e1180f80ab710f..cf1e93b7025248d99be4ba8723fdbdfc408c318b 100644 (file)
@@ -1,2 +1,3 @@
 DIST jaraco.functools-1.12.tar.gz 8819 SHA256 3f3af1cdc15355e8038a3bab0e8393cd7344c63ea5cdb4a81a3422d91c0bfdd2 SHA512 aafb9025e4e99b2469287b2e05161c89622809cd85b2916a65f11654ee5889811bc0def244215e0bbbd5428fa65a2f148229247929ec34b75b548b8e746d8fd0 WHIRLPOOL 6a2d39596473c29172f56ac767d26fd75ae3396b3fb66f5f9bd5b05b9f363d6ac18af614e7b500f0fdf165c3f49426f33c86289ad9546e398f484e31939eaec4
 DIST jaraco.functools-1.13.tar.gz 9026 SHA256 af9033b6aa974cfc70e4abec2be71f2434453b80db1b6f031d2ab26ee5b0eef9 SHA512 fb73a69811026562e1f8195960956a90757700ce13dbc00feb0ef97cf5f3c35f0334bcd7d5529ddab7c7524899bbcc6e264266a4cfe23056b50cd7a3cd9e896b WHIRLPOOL 14a59d390ff8e940d276181559d96fae4e2d5be8a1247b7cb892b452498953c3ed7881fa42dba5bd56dfd95093e8b3db3d3fc819253973828ff812e820acd8f1
+DIST jaraco.functools-1.15.1.tar.gz 8744 SHA256 ca8b594d38c64884f54d6ea36b859227686a54c03cbda6a0fd9da9c3e40514da SHA512 0b65bc36a2338775d4879dd7502b50b930a12458512061ceba65ada86df2658f4fcce4a4e523580239b302a34a8bf90adcfdeaf8f0b2169d704a3a74457424bb WHIRLPOOL 81f91008dfe76fa91b4e54791a895678cd1dc13050339d00bdec90e39abb2ae7492c8f6c61b63c9e104e18ce1e56ae66ada9d9d3d28df07e48e6d66fea20a389
diff --git a/dev-python/jaraco-functools/jaraco-functools-1.15.1.ebuild b/dev-python/jaraco-functools/jaraco-functools-1.15.1.ebuild
new file mode 100644 (file)
index 0000000..3ff6ad8
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.functools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+       dev-python/more-itertools[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/rst-linker[${PYTHON_USEDEP}]
+       )
+       test? (
+               ${RDEPEND}
+               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+               dev-python/pytest-runner[${PYTHON_USEDEP}]
+               dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+       )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+       use doc && esetup.py build_sphinx
+}
+
+python_test() {
+       PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+       distutils-r1_python_install_all
+}