sys-libs/cracklib: version bump to 2.9.6
authorMike Frysinger <vapier@gentoo.org>
Wed, 19 Aug 2015 02:41:23 +0000 (22:41 -0400)
committerMike Frysinger <vapier@gentoo.org>
Wed, 19 Aug 2015 02:42:32 +0000 (22:42 -0400)
sys-libs/cracklib/Manifest
sys-libs/cracklib/cracklib-2.9.6.ebuild [new file with mode: 0644]

index 442385158cdd9ba07af1bfe1d83b1e3bffdf7978..66b748f9641fb65fd5b5790daa587f015bcf7329 100644 (file)
@@ -1,3 +1,4 @@
 DIST cracklib-2.9.1.tar.gz 635123 SHA256 408905c2539a97dc8cbbb6d7cd2046cb5647a345b4bda399220d9471be16d156 SHA512 19b1d38dfcfce98893e6a63e4387a8da9da1eae109d9d84e0f84adabc0ee25fac930576011fb60de007f59f7dea2ee0bb01fd6d8607d4854b7de006ec07a4b2a WHIRLPOOL ff3a71cb81535dde5ad63f51f9c8d5807c91ff5394e8336bac69708357804b8efc7816b2cfe32529777f18e9ba50c22af054b8d5ccff3d4b837a92d85b64dc80
 DIST cracklib-2.9.4.tar.gz 622478 SHA256 f2a866b4b9808344228ea6d68b69e3ba9a8a99210e23dfd718d4b95c60be8958 SHA512 4c94af41d5734e737576221620236951c083f45a7a8061d22ec174c283b91bf64b781ee8dddb91f459f5008ca70f1adfe59c311f082a7a7fecd5214705512a63 WHIRLPOOL 2d9fe10dbc50a45ec3e295e7c5aee3e327f1d7728811c33693bafcffad833e953a4425c4aac7c2556b75aa84a76b1a81bbfd2210d47555086cc4ddd5fd1f7eee
 DIST cracklib-2.9.5.tar.gz 622499 SHA256 59ab0138bc8cf90cccb8509b6969a024d5e58d2d02bcbdccbb9ba9b88be3fa33 SHA512 2362419deb9024b8d761f8349210a25c3182568bb4a4ecf59b1f221ad0c9bd6049fb26eafe853d55b50dcca5f66c695d58b432c70d14054db704ca28a68aa2e2 WHIRLPOOL 72210f50de508fcc70566aabce303c0d1cb09da71385808a2c50808bf8a894b16210633b492f6cd702af51024da0a5850a36e9b5a7542a1313b93bd350f53c35
+DIST cracklib-2.9.6.tar.gz 642402 SHA256 17cf76943de272fd579ed831a1fd85339b393f8d00bf9e0d17c91e972f583343 SHA512 2b09672e5b412d670e7ed911ebf0c0023fe2901ea05c9c02eefb7a58a13cddbc27a65d75bb20be9f8cebf4c90a9a56dfe1a3b656dff62b1d6048f5376e671786 WHIRLPOOL 2b7b908952166e07aedfca7d17423a8dff0ec145a5f34a7ec01571cb591f0e92e57dd25ab6ffff15f1ec276bfefa455072fc7741e664115a4fafdd7f75d580e1
diff --git a/sys-libs/cracklib/cracklib-2.9.6.ebuild b/sys-libs/cracklib/cracklib-2.9.6.ebuild
new file mode 100644 (file)
index 0000000..b430d45
--- /dev/null
@@ -0,0 +1,105 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit eutils distutils-r1 libtool multilib-minimal toolchain-funcs
+
+MY_P=${P/_}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="https://github.com/cracklib/cracklib/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="nls python static-libs test zlib"
+
+RDEPEND="zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       python? (
+               dev-python/setuptools[${PYTHON_USEDEP}]
+               test? ( dev-python/nose[${PYTHON_USEDEP}] )
+       )"
+RDEPEND="${RDEPEND}
+       abi_x86_32? (
+               !<=app-emulation/emul-linux-x86-baselibs-20140508-r6
+               !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+       )"
+
+S=${WORKDIR}/${MY_P}
+
+do_python() {
+       multilib_is_native_abi || return 0
+       use python || return 0
+       pushd python > /dev/null || die
+       distutils-r1_src_${EBUILD_PHASE}
+       popd > /dev/null
+}
+
+pkg_setup() {
+       # workaround #195017
+       if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
+               eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
+               eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+               die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+       fi
+}
+
+src_prepare() {
+       elibtoolize #269003
+       do_python
+}
+
+multilib_src_configure() {
+       export ac_cv_header_zlib_h=$(usex zlib)
+       export ac_cv_search_gzopen=$(usex zlib -lz no)
+       # use /usr/lib so that the dictionary is shared between ABIs
+       ECONF_SOURCE=${S} \
+       econf \
+               --with-default-dict='/usr/lib/cracklib_dict' \
+               --without-python \
+               $(use_enable nls) \
+               $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+       default
+       do_python
+}
+
+multilib_src_test() {
+       do_python
+}
+
+python_test() {
+       nosetests -w "${S}"/python || die "Tests fail with ${EPYTHON}"
+}
+
+multilib_src_install() {
+       default
+       # move shared libs to /
+       multilib_is_native_abi && gen_usr_ldscript -a crack
+
+       do_python
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       prune_libtool_files
+       rm -r "${ED}"/usr/share/cracklib
+
+       insinto /usr/share/dict
+       doins dicts/cracklib-small || die
+}
+
+pkg_postinst() {
+       if [[ ${ROOT} == "/" ]] ; then
+               ebegin "Regenerating cracklib dictionary"
+               create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
+               eend $?
+       fi
+}