dev-libs/pugixml: version bump to 1.10
authorTim Harder <radhermit@gentoo.org>
Thu, 16 Jan 2020 15:42:14 +0000 (08:42 -0700)
committerTim Harder <radhermit@gentoo.org>
Thu, 16 Jan 2020 15:45:32 +0000 (08:45 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-libs/pugixml/Manifest
dev-libs/pugixml/pugixml-1.10.ebuild [new file with mode: 0644]

index 0bcbab4e0b016b8387f8a2bc2c373ca9d7ac21b6..dbf5dcb057985b7468a865c4277afea7d3421a39 100644 (file)
@@ -1 +1,2 @@
+DIST pugixml-1.10.tar.gz 381990 BLAKE2B ea446d11fe5213a5250b7e737a9e80a3976454724e1a1c326b689214ad4d3e183abd417a7782b3d5c68a0aabce42228e121352e4d2dd33f5f2bb2334f6c72c27 SHA512 bfc80661005d0a0fb82ca6d5299e5efdd1bb468e11ee52d7ee9367e15776d28efb60266ce03842715cd43aae023afc2b369797bb3cbecd6d6a65c3ae3903e469
 DIST pugixml-1.9.tar.gz 377369 BLAKE2B 39b5b0d63a20e9c15c5634e56f82207aed63843d252900db94dbf06d100d03916a16523ccb9de433cc94ded4a9e9d1dc11f47bfd6fd75e348a9a2af31c305db6 SHA512 853a9d985aae537391c6524d5413ef4de237d99d96cc58ea7fe7152f786df1e408cdacd2e4387697e23c3e67cdc1d42b29de554501309eae16d86edd0e24785f
diff --git a/dev-libs/pugixml/pugixml-1.10.ebuild b/dev-libs/pugixml/pugixml-1.10.ebuild
new file mode 100644 (file)
index 0000000..4e1d8c3
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
+
+LICENSE="MIT"
+SLOT="0"