app-backup/burp: bump to 2.1.22
authorMarek Szuba <marecki@gentoo.org>
Fri, 17 Nov 2017 09:10:13 +0000 (10:10 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 17 Nov 2017 09:15:44 +0000 (10:15 +0100)
Note that this ebuild fails the test phase when linked against
<net-libs/librsync-2.0.1. Upstream has been notified and already
fixed the problem in the master branch, meanwhile however just let it
slide - it only occurs if you combine an unstable version of burp with a
stable version of librsync.

Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-backup/burp/Manifest
app-backup/burp/burp-2.1.22.ebuild [new file with mode: 0644]

index f823ce4343e89b563af41d70eeb540af0514a647..d8b094df5f7357052728cfa77c1eb5fbb5894780 100644 (file)
@@ -1,3 +1,4 @@
 DIST burp-1.4.40.tar.bz2 712937 SHA256 4108eb45e14740de990d918a2adbb661d88f90de48d6e2e3a6b54fd12b16fa5e SHA512 b44ba3a63d3b75f6fee55bbfef70ac07fa87e78ddb22a398e31a86670dfa3f2db1c9dbc58de3d0038cdc409bd5ae52c8e901cb26975fd7dbe0f773c4841af10c WHIRLPOOL 636120b3fa2d4a3217567177f3c8abbdeb562d298043fd6bd685842287964d835f2a369e36db0bc32ce908ce8f96e4e2677569e6ca4bac80f8d9958a2364a62d
 DIST burp-2.0.54.tar.gz 558845 SHA256 26130da9791c57b1e194973ef1ea292dec57468bf4291a4d0eae880d192c1fd1 SHA512 dccc4d3679dd759028cd6b71d09ae4e49a511e5d94b4df2f112ad974abb507bbc8fffaf63ef85c847b0f9363b20a9e817179ab556c5a788acacb7a25e7600fa4 WHIRLPOOL 60e9bec56c08bc7ebc4700824eab34cf8cefdc5871140471eec5e05dbff4f4b83c2f7c6d5554d33dbb918f46e2c60159ba99a5da599938acd40b9d5b7b582978
 DIST burp-2.1.20.tar.gz 579488 SHA256 225f8ac0ad80ef4fa19c77c2d397d6829086a29dd8ab3d762820b9862d8b8f5c SHA512 5937187e0c93e21b4e3f4ab92f05589f8da56c774cf86644f095a0bff93c127911b2d513c04e380188956c2a97fb01ce471bb746d630baa5d30e6a70b53a0389 WHIRLPOOL b1253df69e20c9448249e14c898cdabc40ba5cbe5e5da5e20c8c4d7e161bf498b9f8a7ead80175d1bf00ad4b0bc893436abde27e37b61b1fad1792de04f16e99
+DIST burp-2.1.22.tar.gz 582938 SHA256 052eaa3d30392e00ec63d30587d4748d468ebb78f40f6c9612355e93f8add093 SHA512 028b48c585cdc607eb00af5f60e01541a54885b8084e0353d01b1e01744848967011cd330a443ae143884852c2dbc18fb25f364ce129a31ccbcf0f8d25ccb730 WHIRLPOOL 0cb271fc384fbb407e8cfb69c8baa1bbf42f5d2539a14c6db1787fafec9ecb8c72f8b8013093176c868fab98c32e99cd8b6a6c259dc71244f13fb6d9638107e1
diff --git a/app-backup/burp/burp-2.1.22.ebuild b/app-backup/burp/burp-2.1.22.ebuild
new file mode 100644 (file)
index 0000000..ca210f8
--- /dev/null
@@ -0,0 +1,113 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools systemd tmpfiles user versionator
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="http://burp.grke.org/"
+SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl ipv6 libressl test xattr"
+
+CDEPEND="dev-libs/uthash
+       net-libs/librsync
+       sys-libs/ncurses:0=
+       sys-libs/zlib
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       acl? ( sys-apps/acl )
+       xattr? ( sys-apps/attr )"
+DEPEND="${CDEPEND}
+       virtual/pkgconfig
+       test? ( dev-libs/check )"
+RDEPEND="${CDEPEND}
+       virtual/logger"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
+       "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
+       "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+)
+
+pkg_setup() {
+       enewgroup "${PN}"
+       enewuser "${PN}" -1 "" "" "${PN}"
+}
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --localstatedir=/var
+               --sysconfdir=/etc/burp
+               --enable-largefile
+               $(use_enable acl)
+               $(use_enable ipv6)
+               $(use_enable xattr)
+       )
+       # --runstatedir option will only work from autoconf-2.70 onwards
+       runstatedir='/run/burp' \
+               econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+       fowners -R root:${PN} /var/spool/burp
+       fperms 0770 /var/spool/burp
+
+       emake DESTDIR="${D}" install-configs
+       fowners -R root:${PN} /etc/burp
+       fperms 0775 /etc/burp
+       fperms 0640 /etc/burp/burp-server.conf
+       fperms 0750 /etc/burp/clientconfdir
+
+       newinitd "${FILESDIR}"/${PN}2.initd ${PN}
+       systemd_dounit "${FILESDIR}"/${PN}.service
+
+       newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
+}
+
+pkg_postinst() {
+       tmpfiles_process ${PN}.conf
+
+       elog "Burp ebuilds now support the autoupgrade mechanism in both"
+       elog "client and server mode. In both cases it is disabled by"
+       elog "default. You almost certainly do NOT want to enable it in"
+       elog "client mode because upgrades obtained this way will not be"
+       elog "managed by Portage."
+
+       if [[ ! -e /etc/burp/CA/index.txt ]]; then
+               elog ""
+               elog "At first run burp server will generate DH parameters and SSL"
+               elog "certificates.  You should adjust configuration before."
+               elog "Server configuration is located at"
+               elog ""
+               elog "  /etc/burp/burp-server.conf"
+               elog ""
+       fi
+
+       # According to PMS this can be a space-separated list of version
+       # numbers, even though in practice it is typically just one.
+       local oldver
+       for oldver in ${REPLACING_VERSIONS}; do
+               if [[ $(get_major_version ${oldver}) -lt 2 ]]; then
+                       ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
+                       ewarn "the server config file by default. If you use bedup, please"
+                       ewarn "update your scripts to invoke it as"
+                       ewarn ""
+                       ewarn "  bedup -c /etc/burp/burp-server.conf"
+                       ewarn ""
+                       ewarn "Otherwise deduplication will not work!"
+                       break
+               fi
+       done
+}