net-mail/mswatch: Fix gcc6 support, bug #594226 by Peter Levine, drop autotools-utils...
authorPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 15:37:27 +0000 (17:37 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 15:38:46 +0000 (17:38 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

net-mail/mswatch/files/mswatch-1.2.0-gcc6.patch [new file with mode: 0644]
net-mail/mswatch/mswatch-1.2.0-r1.ebuild [moved from net-mail/mswatch/mswatch-1.2.0.ebuild with 60% similarity]

diff --git a/net-mail/mswatch/files/mswatch-1.2.0-gcc6.patch b/net-mail/mswatch/files/mswatch-1.2.0-gcc6.patch
new file mode 100644 (file)
index 0000000..2b4fa4c
--- /dev/null
@@ -0,0 +1,12 @@
+--- mswatch-1.2.0/src/lib/util.h.old   2016-09-23 19:09:54.195069503 -0400
++++ mswatch-1.2.0/src/lib/util.h       2016-09-23 19:10:04.663460768 -0400
+@@ -21,9 +21,6 @@
+ void drain_fd(int fd);
+-// static assert, for compile-time assertion checking
+-#define static_assert(x) switch (x) case 0: case (x):
+-
+ __END_DECLS
similarity index 60%
rename from net-mail/mswatch/mswatch-1.2.0.ebuild
rename to net-mail/mswatch/mswatch-1.2.0-r1.ebuild
index 7f4ba1a6d78647295a93f41a0bb423bfb6261693..06d3a3d1712509f841febfdb5c625fddf3e97ef1 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
-
-inherit linux-info autotools-utils
+EAPI=6
+inherit linux-info ltprune
 
 DESCRIPTION="A utility to watch mailstores for changes and initiate mailbox syncs"
 HOMEPAGE="http://mswatch.sourceforge.net/"
@@ -16,17 +15,25 @@ IUSE="static-libs"
 
 RDEPEND=">=dev-libs/glib-2.6:2"
 DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+       virtual/pkgconfig
+"
 
 CONFIG_CHECK="~INOTIFY_USER"
 ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
 
-DOCS=( AUTHORS NEWS README THANKS TODO )
-PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
+PATCHES=(
+       "${FILESDIR}"/${P}-gcc47.patch
+       "${FILESDIR}"/${P}-gcc6.patch
+)
 
 src_configure() {
-       local myeconfargs=(
-               --with-notify=inotify
-       )
-       autotools-utils_src_configure
+       econf \
+               --with-notify=inotify \
+               --enable-shared \
+               $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       prune_libtool_files
 }