dev-ros/combined_robot_hw_tests: Bump to 0.15.0.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 17 Jul 2018 06:58:47 +0000 (08:58 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 17 Jul 2018 06:58:47 +0000 (08:58 +0200)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

dev-ros/combined_robot_hw_tests/Manifest
dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.15.0.ebuild [new file with mode: 0644]

index 0edeabcdeec3d110937bf7a784c30966c87936a0..d459139029c5e58b82288d0f0f802a7aa96fdce5 100644 (file)
@@ -1 +1,2 @@
 DIST ros_control-0.14.2.tar.gz 655686 BLAKE2B e3cf0ce87c8d5324f202c1e15ece973b004d7719e30577a5661c478278826da715cd2d54f62d6def0e447d7d7ec26c3d4f4c7b2fd3c548bff960a6bdf0258fa4 SHA512 8368ae786ca0621fc560f6bc32e754757da0f3e4594039425047d3370c5c55a4a2836dc220452d47df49df1e609d79de976c0fe45d83bd62cff64fd5549f993b
+DIST ros_control-0.15.0.tar.gz 657854 BLAKE2B 102c17265df13d4454249f9752491664d9c8d4354c417e99aaf7845fbea2992fbfde674e22e8415e4b55274aba6964473cc6663c0784f78cf7bb87fc232d5c30 SHA512 be1b208631a3018f06384bf342f6d909b082d48e5509bb2bdac1ce04eddad56ac83f8cf5c10a0c66650c2c7defa04680950bf5417723e2f8551055051c4fcc99
diff --git a/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.15.0.ebuild b/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..e23c205
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Combined Robot HW class tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/combined_robot_hw
+       dev-ros/controller_manager
+       dev-ros/controller_manager_tests
+       dev-ros/hardware_interface
+       dev-ros/roscpp
+       dev-libs/boost:=
+       dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"