dev-python/elasticsearch-curator: bump to 5.8.1
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 25 Oct 2019 09:48:11 +0000 (11:48 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 28 Oct 2019 14:42:03 +0000 (16:42 +0200)
Closes: https://bugs.gentoo.org/696632
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13424
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/elasticsearch-curator/Manifest
dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1.ebuild [new file with mode: 0644]

index 3d7731c867f7b98abc4d6852ce42242918487c72..cc3cbecf2ab1c7aa40009ffe934d85d93789d2b9 100644 (file)
@@ -1,4 +1,6 @@
+DIST elasticsearch-7.3.2-linux-x86_64.tar.gz 285050383 BLAKE2B 730d8550f5887facae3075ce3b0bdb96b49350782fe7e687b8f4477bb363ce7c1595f2b1ece2b7d59d18539886b6e4806f56b0f5674bc417528232a92f1c00a8 SHA512 08e89347797ec6f008fb76cda17ec3e0dbc553fc992d07f4944fd99d17d5bc934849d9e534724d1541432c9844d3da57d875bc08a0c4cd95ba4251e2b03f833b
 DIST elasticsearch-curator-5.5.4.tar.gz 221161 BLAKE2B 41828800dd9237142767d3163b3d87770ea5b904858991598cce2feb7c3a22d85c0d73275a2f232099ea82e7346fc20080a3bfef692ee808b730d3e4e6de405d SHA512 99ed18592105d19791513ad713115b6e2a6b589ab8b4e3fc4435b2878e25f552e0bda8d63cb6279970afc6ba39d9f3db17af1b4fb44500fe8a14b060e1530258
 DIST elasticsearch-curator-5.6.0.tar.gz 221555 BLAKE2B cbf1f645b266d2d08914ff74fd5c63bcd5661ef68a8b9286ed59b05d52d50e18e8d18e00b3a0e037f8e6452ce79213280b5ecffaf6af0a3fb70ef92458c80efa SHA512 7dc02b5d15228ea96254dc7dd8069d8396c5d3df883b7ab42936c7612b0f16f5399131563703ccd05469facee7ddf20a720daf62a2713943a4b9a0c9448dd676
+DIST elasticsearch-curator-5.8.1.tar.gz 231233 BLAKE2B d2369c18be69cc5c8e17a6d7a72660bd7165c349cdb06c740c8db9dd2b583f181a09ba7d53ee0f4692cb6e31d373274f0610f2a654ba4a6da2d0ca0ff22c7c97 SHA512 500767967f423629f34d42ee088a9c007e193216c42f5590364ffcacc9e1efeba65dd4d333f806250e3b7fe0bea8b5501d1e6f3bf6fb0b8c46a46954e92c4a65
 DIST elasticsearch-oss-6.3.2.tar.gz 29418577 BLAKE2B 152640dc01a10f44ba43f87f68361cc0dd5e1cf54d0ff92377f3acd1a12a247f002ffe2d003cc53760e891278249c10b1d6d4eb978b0bb1c1ebf8879a2cfcb9a SHA512 3c51a860414f7e55900b1d9a350bdbc3e673c8445e316454c2480315b4b9fc08df58090c6281cecc3ae63d12d78d6bd58e228b3371aa325db799ce18758a21f4
 DIST elasticsearch-oss-6.4.3.tar.gz 33727639 BLAKE2B b4f4821af7a2447a6a16158c32bf676ebbfd8598fde8af558dd19d6e365df66be17d0984e3acb9380a0d5e0cff486b85f6edf96312bd3bb3fc5ae52c270306f3 SHA512 b1147baa95119a8a96779125351358b4c62f2a546b65a9750c11d1d1b9270f06db6da8ff1d9ad11efade1eaea8487087e2d8839b0edfc5da6d9b54da6c6df4e7
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-5.8.1.ebuild
new file mode 100644 (file)
index 0000000..f822977
--- /dev/null
@@ -0,0 +1,159 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+MY_PN="curator"
+ES_VERSION="7.3.2"
+
+inherit distutils-r1
+
+DESCRIPTION="Tending time-series indices in Elasticsearch"
+HOMEPAGE="https://github.com/elasticsearch/curator"
+SRC_URI="https://github.com/elasticsearch/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-${ES_VERSION}-linux-x86_64.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests fail in chroot
+# https://github.com/elastic/elasticsearch/issues/12018
+RESTRICT="test"
+IUSE="doc test"
+
+# vulnerable pyyaml
+# https://github.com/elastic/curator/issues/1415
+RDEPEND="
+       >=dev-python/elasticsearch-py-7.0.4[${PYTHON_USEDEP}]
+       <dev-python/elasticsearch-py-8.0.0[${PYTHON_USEDEP}]
+       >=dev-python/click-6.7[${PYTHON_USEDEP}]
+       <dev-python/click-7.0[${PYTHON_USEDEP}]
+       >=dev-python/certifi-2019.9.11[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+       >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]
+       <dev-python/urllib3-1.25[${PYTHON_USEDEP}]
+       >=dev-python/voluptuous-0.9.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+       dev-python/sphinx
+       ~dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND}
+               virtual/jre
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/six[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+       # avoid downloading from net
+       sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+
+       # requests_aws4auth not in portage
+       sed -e '/boto3/d' \
+               -e '/requests_aws4auth/d' \
+               -e '/tests_require/s/, "coverage", "nosexcover"//g' \
+               -i setup.cfg setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       emake -C docs -j1 man $(usex doc html "")
+}
+
+# running tests in non-chroot environments:
+# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-curator
+python_test_all() {
+       # starts two ES instances (local,remote) and runs the tests
+       # https://github.com/elastic/curator/blob/master/travis-run.sh
+       local ES_INSTANCES="local remote"
+       local ES_PATH="${WORKDIR}/elasticsearch-${ES_VERSION}"
+
+       declare -A ES_PORT
+       ES_PORT[local]=9200
+       ES_PORT[remote]=9201
+
+       local i transport
+       declare -A ES_CONFIG_DIR ES_CONFIG_PATH ES_INSTANCE ES_LOG ES_PID
+       for i in ${ES_INSTANCES}; do
+               ES_CONFIG_DIR[$i]="${ES_PATH}/$i"
+               ES_CONFIG_PATH[$i]="${ES_CONFIG_DIR[$i]}/elasticsearch.yml"
+               ES_PID[$i]="${ES_PATH}/$i.pid"
+               ES_LOG[$i]="${ES_PATH}/logs/$i.log"
+       done
+
+       # configure ES instances
+       for i in ${ES_INSTANCES}; do
+               mkdir -p "${ES_CONFIG_DIR[$i]}" || die
+               cp ${ES_PATH}/config/{jvm.options,log4j2.properties} "${ES_CONFIG_DIR[$i]}"/ || die
+               echo 'network.host: 127.0.0.1' > "${ES_CONFIG_PATH[$i]}" || die
+               echo "http.port: ${ES_PORT[$i]}" >> "${ES_CONFIG_PATH[$i]}" || die
+               echo "cluster.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
+               echo "node.name: $i" >> "${ES_CONFIG_PATH[$i]}" || die
+               echo 'node.max_local_storage_nodes: 2' >> "${ES_CONFIG_PATH[$i]}" || die
+               transport=$((${ES_PORT[$i]}+100))
+               echo "transport.port: ${transport}" >> "${ES_CONFIG_PATH[$i]}" || die
+               echo "discovery.seed_hosts: [\"localhost:${transport}\"]" >> "${ES_CONFIG_PATH[$i]}" || die
+               echo "discovery.type: single-node" >> "${ES_CONFIG_PATH[$i]}" || die
+       done
+
+       echo 'path.repo: /' >> "${ES_CONFIG_PATH[local]}" || die
+       echo "reindex.remote.whitelist: localhost:${ES_PORT[remote]}" >> "${ES_CONFIG_PATH[local]}" || die
+
+       # start ES instances
+       for i in ${ES_INSTANCES}; do
+               ES_PATH_CONF=${ES_CONFIG_DIR[$i]} "${ES_PATH}/bin/elasticsearch" -d -p "${ES_PID[$i]}" || die
+
+               local j
+               local es_started=0
+               for j in {1..30}; do
+                       grep -q "started" "${ES_LOG[$i]}" 2> /dev/null
+                       if [[ $? -eq 0 ]]; then
+                               einfo "Elasticsearch $i started"
+                               es_started=1
+                               eend 0
+                               break
+                       elif grep -q 'BindException\[Address already in use\]' "${ES_LOG[$i]}" 2>/dev/null; then
+                               eend 1
+                               eerror "Elasticsearch $i already running"
+                               die "Cannot start Elasticsearch $i for tests"
+                       else
+                               einfo "Waiting for Elasticsearch $i"
+                               eend 1
+                               sleep 2
+                               continue
+                       fi
+               done
+
+               [[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"
+       done
+
+       export TEST_ES_SERVER="localhost:${ES_PORT[local]}"
+       export REMOTE_ES_SERVER="localhost:${ES_PORT[remote]}"
+
+       # run tests
+       nosetests -v || die
+
+       for i in ${ES_INSTANCES}; do
+               pkill -F ${ES_PID[$i]}
+       done
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       doman docs/_build/man/*
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       ewarn ""
+       ewarn "For Python 3 support information please read: http://click.pocoo.org/latest/python3/"
+       ewarn ""
+       ewarn "Example usage on Python 3:"
+       ewarn "export LC_ALL=en_US.UTF-8"
+       ewarn "export LANG=en_US.UTF-8"
+       ewarn "curator ..."
+}