dev-perl/MaxMind-DB-Common: Add w/ v=0.40.1
authorKent Fredric <kentnl@gentoo.org>
Tue, 4 Feb 2020 03:14:09 +0000 (16:14 +1300)
committerKent Fredric <kentnl@gentoo.org>
Wed, 5 Feb 2020 01:01:53 +0000 (14:01 +1300)
Required for dev-perl/GeoIP2, as suggested by Tomáš Mózes

Bug: https://github.com/gentoo/gentoo/pull/13973
Bug: https://bugs.gentoo.org/675494
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/MaxMind-DB-Common/Manifest [new file with mode: 0644]
dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild [new file with mode: 0644]
dev-perl/MaxMind-DB-Common/metadata.xml [new file with mode: 0644]

diff --git a/dev-perl/MaxMind-DB-Common/Manifest b/dev-perl/MaxMind-DB-Common/Manifest
new file mode 100644 (file)
index 0000000..94abd2d
--- /dev/null
@@ -0,0 +1 @@
+DIST MaxMind-DB-Common-0.040001.tar.gz 22195 BLAKE2B c242abe2786bebb4f045d8e454e5044fa7c53db77b589e2d49f37d21f59d221e5ed543aa15c906cf8259b15b217b1bb103f5034c1ffdb10b6c2d89e2b5e97183 SHA512 4748ac66e09ec3c8017b7365562b8273399c85f359c35b22868e1b86e80e8a59a3a3fbfd851becf0ac997657b4e8288057204a2e14bb699815676f3214f6345c
diff --git a/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild b/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild
new file mode 100644 (file)
index 0000000..cbe7dca
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MAXMIND
+DIST_VERSION=0.040001
+inherit perl-module
+
+DESCRIPTION="Code shared by the MaxMind DB reader and writer modules"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-Carp
+       dev-perl/Data-Dumper-Concise
+       dev-perl/DateTime
+       virtual/perl-Exporter
+       dev-perl/List-AllUtils
+       virtual/perl-Math-BigInt
+       dev-perl/Moo
+       dev-perl/MooX-StrictConstructor
+       virtual/perl-Scalar-List-Utils
+       dev-perl/Sub-Quote
+       virtual/perl-autodie
+       dev-perl/namespace-autoclean
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-File-Spec
+               >=virtual/perl-Test-Simple-0.960.0
+       )
+"
+PERL_RM_FILES=(
+       "t/author-00-compile.t"
+       "t/author-eol.t"
+       "t/author-no-tabs.t"
+       "t/author-pod-spell.t"
+       "t/author-pod-syntax.t"
+       "t/author-test-version.t"
+       "t/release-cpan-changes.t"
+       "t/release-portability.t"
+       "t/release-synopsis.t"
+       "t/release-tidyall.t"
+)
diff --git a/dev-perl/MaxMind-DB-Common/metadata.xml b/dev-perl/MaxMind-DB-Common/metadata.xml
new file mode 100644 (file)
index 0000000..dec1ce3
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>perl@gentoo.org</email>
+    <name>Gentoo Perl Project</name>
+  </maintainer>
+  <maintainer type="person">
+    <email>hydrapolic@gmail.com</email>
+    <name>Tomáš Mózes</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="cpan">MaxMind-DB-Common</remote-id>
+    <remote-id type="cpan-module">MaxMind::DB::Common</remote-id>
+    <remote-id type="cpan-module">MaxMind::DB::Metadata</remote-id>
+    <remote-id type="cpan-module">MaxMind::DB::Role::Debugs</remote-id>
+    <remote-id type="cpan-module">MaxMind::DB::Types</remote-id>
+    <remote-id type="cpan-module">Test::MaxMind::DB::Common::Data</remote-id>
+    <remote-id type="cpan-module">Test::MaxMind::DB::Common::Util</remote-id>
+  </upstream>
+</pkgmetadata>