media-gfx/entangle: Prebuild enum targets to fix race condition
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 07:27:10 +0000 (08:27 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 07:35:50 +0000 (08:35 +0100)
Closes: https://bugs.gentoo.org/709740
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-gfx/entangle/entangle-2.0.ebuild

index a8563923bc55c412c060b2ec64bbd33f35b79675..8e23c27d8c6588486d4934ebc9062eb66eddc6b6 100644 (file)
@@ -48,6 +48,11 @@ src_compile() {
        # prevent gst from loading system plugins which causes
        # sandbox violations on device access
        local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+       # pre-generate enums to resolve race conditions
+       # https://bugs.gentoo.org/709740
+       meson_src_compile \
+               src/backend/entangle-{camera,colour-profile}-enums.h \
+               src/frontend/entangle-image-display-enums.h
        meson_src_compile
 }