dev-python/autobahn: Ignore possible file doesn't exist error
authorBrian Dolbec <dolsen@gentoo.org>
Sun, 10 May 2020 08:11:32 +0000 (01:11 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Sun, 10 May 2020 08:20:36 +0000 (01:20 -0700)
When upgrading from older autobahn versions, the twisted plugin cache
is not updated in the build environment. So ignore the error, allow it to fail
with a file collision if it failed to delete it and it still exists.

bug: https://bugs.gentoo.org/721986

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
dev-python/autobahn/autobahn-20.4.3.ebuild

index b9380e38dc988057cda7bfde1fcf5ed9991092c6..396e8da241b27c12b8999f395d49557b9e768568 100644 (file)
@@ -71,8 +71,8 @@ python_test() {
 python_install_all() {
        distutils-r1_python_install_all
 
-       # delete the dropin.cache so we don't have collisions
-       rm "${D}"/usr/lib*/python*/site-packages/twisted/plugins//dropin.cache || die
+       # delete the dropin.cache so we don't have collisions if it exists
+       rm "${D}"/usr/lib*/python*/site-packages/twisted/plugins//dropin.cache > /dev/null
 }
 
 pkg_postinst() {