dev-util/catalyst: Version bump to 3.0.7
authorMatt Turner <mattst88@gentoo.org>
Sun, 20 Oct 2019 00:03:11 +0000 (17:03 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sun, 20 Oct 2019 00:04:26 +0000 (17:04 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-util/catalyst/Manifest
dev-util/catalyst/catalyst-3.0.7.ebuild [new file with mode: 0644]

index 171a8fa7651cc2e95251ac6a7d6175511153dc6f..1b7fb027e44df00ee80c493eab6bc4c56bc1e60b 100644 (file)
@@ -1,2 +1,3 @@
 DIST catalyst-3.0.5.tar.bz2 873286 BLAKE2B c4cafccb0dcee19d6b0dd30e57c99da81b3485342b6d5405cdbe2e2b59a4631f3223e7d13c5041783a7172361b4a1b69ee5ff68e29ee8bec2f76165acdc5686c SHA512 35cc16391100394f97af4cdfd14f9de2ab4532c97c213f43dd0be927766dc3892768be5aa899fc8919414743c9ea63b4489a2690437b3e7985951eb68c19d0a4
 DIST catalyst-3.0.6.tar.bz2 873468 BLAKE2B 146228e6a8eca293a93ab50661b1a3852fe587036d2d2ff9fde132ccb1f0642cbdd4332a13f912927ef8e7c5d8dea5bb738aa3327b559e18c7d31308a289a7fc SHA512 01de8405f48c698366cbb675e75ecbe6cfb5a7236d5b5a0f1f9bc6200b07c728fca41925b34177019b207d8ef2c1b688306a37b1571a7fd91138d31e81758bce
+DIST catalyst-3.0.7.tar.bz2 873526 BLAKE2B e056c2ac7589e2423a984c8a089faef87af24d401d4b2c2c4c3752b0af290e42df1fd1f5fd3dad5586fd96b23ecdfa90482f913b2be4181727048cf8fdef8d43 SHA512 403d33c10324e4bfd7c7c2f9a63bc41823230b0450e3e153fb051e8efb18263f1d7f260a11d8acdfa052efa8d41cb2ba4570e65d68c41e342d83477c755e68ab
diff --git a/dev-util/catalyst/catalyst-3.0.7.ebuild b/dev-util/catalyst/catalyst-3.0.7.ebuild
new file mode 100644 (file)
index 0000000..9b191cb
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999* ]]; then
+       SRC_ECLASS="git-r3"
+       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/catalyst.git"
+       EGIT_BRANCH="master"
+else
+       SRC_URI="https://gitweb.gentoo.org/proj/catalyst.git/snapshot/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Catalyst"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache doc +iso kernel_linux system-bootloader"
+
+DEPEND="
+       app-text/asciidoc
+       >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+       >=dev-python/pydecomp-0.3[${PYTHON_USEDEP}]
+       app-arch/lbzip2
+       app-crypt/shash
+       sys-fs/dosfstools
+       !kernel_FreeBSD? ( || ( app-arch/tar[xattr] app-arch/libarchive[xattr] ) )
+       kernel_FreeBSD? ( app-arch/libarchive[xattr] )
+       amd64? ( >=sys-boot/syslinux-3.72 )
+       x86? ( >=sys-boot/syslinux-3.72 )
+       ccache? ( dev-util/ccache )
+       iso? ( virtual/cdrtools )
+       kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+"
+PDEPEND="system-bootloader? ( >=sys-apps/memtest86+-5.01-r4
+                               sys-boot/grub:2
+                               amd64? ( sys-boot/grub[grub_platforms_efi-32,grub_platforms_efi-64] )
+                               x86? ( sys-boot/grub[grub_platforms_efi-32] )
+                               sys-boot/syslinux
+                               sys-boot/shim )"
+
+python_prepare_all() {
+       python_setup
+       echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+       VERSION="${PV}" "${PYTHON}" setup.py set_version || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       # build the man pages and docs
+       emake
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       if use doc; then
+               dodoc files/HOWTO.html files/docbook-xsl.css
+       fi
+}