app-text/xdvik: Call xdg_desktop_database_update() (bug #628826).
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Thu, 28 Sep 2017 16:37:52 +0000 (18:37 +0200)
committerMike Gilbert <floppym@gentoo.org>
Thu, 28 Sep 2017 17:11:00 +0000 (13:11 -0400)
app-text/xdvik/xdvik-22.87.03.ebuild

index 534a820e63346ff1bc779b4b1495e4b85c1ae59c..76037612857236f283285dab1fbe316622ac48ab 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-inherit eutils flag-o-matic elisp-common toolchain-funcs multilib
+inherit elisp-common eutils flag-o-matic multilib toolchain-funcs xdg-utils
 
 DESCRIPTION="DVI previewer for X Window System"
 HOMEPAGE="http://xdvi.sourceforge.net/"
@@ -92,6 +92,8 @@ src_install() {
 }
 
 pkg_postinst() {
+       xdg_desktop_database_update
+
        if use emacs; then
                elog "Add"
                elog "  (add-to-list 'load-path \"${EPREFIX}${SITELISP}/tex-utils\")"
@@ -99,3 +101,7 @@ pkg_postinst() {
                elog "to your ~/.emacs file"
        fi
 }
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}