dev-php/pecl-crack: add PHP 7.3 support
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 13:09:56 +0000 (15:09 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 14:08:02 +0000 (16:08 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-crack/pecl-crack-0.4-r7.ebuild

index 08d5e3ea1c16900e0f3166a8019362c3e0155591..841669f34fdaa0b00837b37b1d24ceb5843e1d87 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI="7"
 
 PHP_EXT_NAME="crack"
 PHP_EXT_INI="yes"
@@ -9,7 +9,7 @@ PHP_EXT_ZENDEXT="no"
 PHP_EXT_EXTRA_ECONF=""
 DOCS=( EXPERIMENTAL )
 
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
 
 inherit php-ext-pecl-r3
 
@@ -19,8 +19,10 @@ DESCRIPTION="PHP interface to the cracklib libraries"
 LICENSE="PHP-3 CRACKLIB"
 SLOT="0"
 IUSE=""
+
 # Patch for http://pecl.php.net/bugs/bug.php?id=5765
-PATCHES=( "${FILESDIR}/fix-php-5-4-support.patch"
-"${FILESDIR}/fix-pecl-bug-5765.patch"
-"${FILESDIR}/${PV}-php7.patch"
+PATCHES=(
+       "${FILESDIR}/fix-php-5-4-support.patch"
+       "${FILESDIR}/fix-pecl-bug-5765.patch"
+       "${FILESDIR}/${PV}-php7.patch"
 )