dev-python/gst-python: bump to 1.16.2, add py3.8 support
authorMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 20:19:29 +0000 (23:19 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 3 May 2020 20:19:37 +0000 (23:19 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-python/gst-python/Manifest
dev-python/gst-python/files/1.16.2-python3.8.patch [new file with mode: 0644]
dev-python/gst-python/gst-python-1.16.2.ebuild [new file with mode: 0644]

index 6df71b4a26876303e81f5b565947e222ebdf9b0a..00f4c0d1a6cfdf5d522c45061da46c2a7c8b6862 100644 (file)
@@ -1 +1,2 @@
 DIST gst-python-1.14.1.tar.xz 405312 BLAKE2B 29be6f79b20a27e0d21f27cbf29b1881216e412c3c4ea016f3ee6bd921ec7b73139f74a20528f7f704526786347b065d246940f152d61a64e4eb926dbb44bb87 SHA512 32537e6556b69d00cb0b467239c148c0b9c282b76786be395e053a30554b84aea7c22e7fe6fc6faf77b35fca82fb799df4f52c114b282d0a6ea660f67dc40c53
+DIST gst-python-1.16.2.tar.xz 414912 BLAKE2B 016e59fc7d29047dcf49901d4ccb1ff2e96950dc723cd7e9dd31e0fe92257e881ced1c93e7e4e531320be8fb9d6cb8382d2c31e460448d5d630ec7c8a0378024 SHA512 c274591cb820a2576ca236de0d1a2c2c53a9db11afc689e0385afe3d38fadc59c9230d65198e79e4059abb90c0e5b6d71f1ee4cf1439d92feaaffd2ab5cd3a23
diff --git a/dev-python/gst-python/files/1.16.2-python3.8.patch b/dev-python/gst-python/files/1.16.2-python3.8.patch
new file mode 100644 (file)
index 0000000..c4b4ddd
--- /dev/null
@@ -0,0 +1,39 @@
+From 22f28155d86e27c4134de4ed2861264003fcfd23 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Fri, 13 Dec 2019 10:46:20 +0200
+Subject: [PATCH] Fix build with Python 3.8 by also checking for
+ python-3.X-embed.pc
+
+Since Python 3.8 the normal checks don't include the Python libraries
+anymore and linking of the gst-python module would fail.
+
+See also https://github.com/mesonbuild/meson/issues/5629
+
+Fixes https://gitlab.freedesktop.org/gstreamer/gst-python/issues/28
+---
+ meson.build | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 744b7ce..fe4ca7a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -24,7 +24,14 @@ pygobject_dep = dependency('pygobject-3.0', fallback: ['pygobject', 'pygobject_d
+ pymod = import('python')
+ python = pymod.find_installation(get_option('python'))
+-python_dep = python.dependency(required : true)
++pythonver = python.language_version()
++
++# Workaround for https://github.com/mesonbuild/meson/issues/5629
++# https://gitlab.freedesktop.org/gstreamer/gst-python/issues/28
++python_dep = dependency('python-@0@-embed'.format(pythonver), version: '>=3', required: false)
++if not python_dep.found()
++  python_dep = python.dependency(required : true)
++endif
+ python_abi_flags = python.get_variable('ABIFLAGS', '')
+ pylib_loc = get_option('libpython-dir')
+-- 
+2.20.1
+
diff --git a/dev-python/gst-python/gst-python-1.16.2.ebuild b/dev-python/gst-python/gst-python-1.16.2.ebuild
new file mode 100644 (file)
index 0000000..d449b21
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       >=media-libs/gstreamer-${PV}:1.0[introspection]
+       >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+       >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PV}-python3.8.patch
+)
+
+src_prepare() {
+       default
+       # Avoid building plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+       # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+       # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+       sed -e '/subdir.*plugin/d' -i meson.build || die
+       xdg_environment_reset
+}
+
+src_configure() {
+       configuring() {
+               meson_src_configure \
+                       -Dpython="${EPYTHON}"
+       }
+       python_foreach_impl configuring
+}
+
+src_compile() {
+       python_foreach_impl meson_src_compile
+}
+
+src_test() {
+       python_foreach_impl meson_src_test
+}
+
+src_install() {
+       installing() {
+               meson_src_install
+               python_optimize
+       }
+       python_foreach_impl installing
+}