Add check for more recent kernels, clean overshadowed and stable on x86
authorMarkus Ullmann <jokey@gentoo.org>
Wed, 18 Apr 2007 17:23:03 +0000 (17:23 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Wed, 18 Apr 2007 17:23:03 +0000 (17:23 +0000)
Package-Manager: portage-2.1.2.3

net-libs/libnfnetlink/ChangeLog
net-libs/libnfnetlink/files/digest-libnfnetlink-0.0.16 [deleted file]
net-libs/libnfnetlink/libnfnetlink-0.0.16.ebuild [deleted file]
net-libs/libnfnetlink/libnfnetlink-0.0.25.ebuild

index e8d89a0359301fbebe66a420e5faaf3a1be136d3..6943c63987efbda8e7b9f26e9211050b1d55b255 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-libs/libnfnetlink
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/ChangeLog,v 1.3 2007/04/15 10:19:24 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/ChangeLog,v 1.4 2007/04/18 17:20:38 jokey Exp $
+
+  18 Apr 2007; Markus Ullmann <jokey@gentoo.org> libnfnetlink-0.0.25.ebuild:
+  Add check for more recent kernels, clean overshadowed and stable on x86
 
   15 Apr 2007; Daniel Black <dragonheart@gentoo.org>
   libnfnetlink-0.0.25.ebuild:
diff --git a/net-libs/libnfnetlink/files/digest-libnfnetlink-0.0.16 b/net-libs/libnfnetlink/files/digest-libnfnetlink-0.0.16
deleted file mode 100644 (file)
index 76c1f98..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5c9b7fc55c5cc7869ecf2ae5ac8afff3 libnfnetlink-0.0.16.tar.bz2 199902
-RMD160 52dcaeaf19e413c4d365e3a6a70fc0f21a477631 libnfnetlink-0.0.16.tar.bz2 199902
-SHA256 7b6593bb3e22bb9c2db35928b36f84256407ca78db5b3049c7d3b135647eba19 libnfnetlink-0.0.16.tar.bz2 199902
diff --git a/net-libs/libnfnetlink/libnfnetlink-0.0.16.ebuild b/net-libs/libnfnetlink/libnfnetlink-0.0.16.ebuild
deleted file mode 100644 (file)
index e3c85c1..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-0.0.16.ebuild,v 1.1 2006/11/13 21:09:57 cedk Exp $
-
-inherit linux-info
-
-DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
-HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
-SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-CONFIG_CHECK="NETFILTER_NETLINK"
-
-pkg_setup() {
-       linux-info_pkg_setup
-       kernel_is lt 2 6 14 && die "requires at least 2.6.14 kernel version"
-}
-
-src_install() {
-       emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc README
-}
index 90990b681744676c4f228d0d18da4f12d5b110d4..12ba9e4843e1c83d767728e4a818dccbf224fbf8 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-0.0.25.ebuild,v 1.2 2007/04/15 10:19:24 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-0.0.25.ebuild,v 1.3 2007/04/18 17:20:38 jokey Exp $
 
 inherit linux-info
 
@@ -10,17 +10,27 @@ SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 x86"
 IUSE=""
 
 DEPEND=""
 RDEPEND=""
 
-CONFIG_CHECK="NETFILTER_NETLINK"
-
 pkg_setup() {
        linux-info_pkg_setup
-       kernel_is lt 2 6 14 && die "requires at least 2.6.14 kernel version"
+
+       if kernel_is lt 2 6 14 ; then
+               die "${PN} requires at least 2.6.14 kernel version"
+       fi
+
+       #netfilter core team has changed some option names with kernel 2.6.20
+       if kernel_is lt 2 6 20 ; then
+               CONFIG_CHECK="IP_NF_CONNTRACK_NETLINK"
+       else
+               CONFIG_CHECK="NF_CT_NETLINK"
+       fi
+
+       check_extra_config
 }
 
 src_install() {