app-emulation/spice: add use flag for lz4 support, avoid automagic; bug #582014
authorMatthias Maier <tamiko@gentoo.org>
Tue, 14 Jun 2016 04:11:37 +0000 (23:11 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 14 Jun 2016 04:11:37 +0000 (23:11 -0500)
Package-Manager: portage-2.2.28

app-emulation/spice/metadata.xml
app-emulation/spice/spice-0.13.1-r1.ebuild [moved from app-emulation/spice/spice-0.13.1.ebuild with 94% similarity]
app-emulation/spice/spice-9999.ebuild

index bc1f503810c13100ff124daad1802dcbe6772cbb..acfc46a7c58898b398eb8652fcc6b11f33edcb88 100644 (file)
@@ -10,6 +10,7 @@
                <name>Gentoo Virtualization Project</name>
        </maintainer>
        <use>
+               <flag name="lz4">Enable support for LZ4 compression using <pkg>app-arch/lz4</pkg></flag>
                <flag name="smartcard">Enable smartcard remoting using <pkg>app-emulation/libcacard</pkg></flag>
        </use>
 </pkgmetadata>
similarity index 94%
rename from app-emulation/spice/spice-0.13.1.ebuild
rename to app-emulation/spice/spice-0.13.1-r1.ebuild
index 46d50a86f10d5e206eccc9b7593c46ececdfc632..be2c0c608cd6088122ff998ae5463d4d9cfaea05 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="libressl sasl smartcard static-libs"
+IUSE="libressl lz4 sasl smartcard static-libs"
 
 # the libspice-server only uses the headers of libcacard
 RDEPEND="
@@ -27,6 +27,7 @@ RDEPEND="
        >=x11-libs/pixman-0.17.7[static-libs(+)?]
        !libressl? ( dev-libs/openssl:0[static-libs(+)?] )
        libressl? ( dev-libs/libressl[static-libs(+)?] )
+       lz4? ( app-arch/lz4 )
        smartcard? ( >=app-emulation/libcacard-0.1.2 )
        sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )"
 
@@ -59,6 +60,7 @@ src_prepare() {
 src_configure() {
        econf \
                $(use_enable static-libs static) \
+               $(use_enable lz4) \
                $(use_with sasl) \
                $(use_enable smartcard) \
                --disable-gui
index 93d4c7a4b0e4a21021195ce29cee3a27b687ed67..f93c735ded1cf9054a7833560f4ed6a577725e72 100644 (file)
@@ -16,7 +16,7 @@ EGIT_REPO_URI="git://git.freedesktop.org/git/spice/spice"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS=""
-IUSE="libressl sasl smartcard static-libs"
+IUSE="libressl lz4 sasl smartcard static-libs"
 
 RDEPEND="
        >=dev-libs/glib-2.22:2[static-libs(+)?]
@@ -27,6 +27,7 @@ RDEPEND="
        >=x11-libs/pixman-0.17.7[static-libs(+)?]
        !libressl? ( dev-libs/openssl:0[static-libs(+)?] )
        libressl? ( dev-libs/libressl[static-libs(+)?] )
+       lz4? ( app-arch/lz4 )
        smartcard? ( >=app-emulation/libcacard-0.1.2 )
        sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )"
 
@@ -50,6 +51,8 @@ pkg_setup() {
 }
 
 src_prepare() {
+       epatch_user
+
        eautoreconf
        default
 }
@@ -57,6 +60,7 @@ src_prepare() {
 src_configure() {
        econf \
                $(use_enable static-libs static) \
+               $(use_enable lz4) \
                $(use_with sasl) \
                $(use_enable smartcard) \
                --disable-gui