media-gfx/graphicsmagick: version bump to 1.3.32
authorTim Harder <radhermit@gentoo.org>
Sun, 16 Jun 2019 02:30:47 +0000 (21:30 -0500)
committerTim Harder <radhermit@gentoo.org>
Sun, 16 Jun 2019 03:50:10 +0000 (22:50 -0500)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
media-gfx/graphicsmagick/Manifest
media-gfx/graphicsmagick/graphicsmagick-1.3.32.ebuild [new file with mode: 0644]
media-gfx/graphicsmagick/graphicsmagick-9999.ebuild

index d438b76630899c43f1eb81561c66fce9be6e4425..f8413f51295fef93dd70236947f10336e866455f 100644 (file)
@@ -1 +1,2 @@
 DIST GraphicsMagick-1.3.30.tar.xz 5496116 BLAKE2B 408f68334b290ae30d06e4b0efa6e11e89ffa9c00781e2f0ceb25cd6fc308f1be86b5ed9bd52f594e1abd3351f1b7dbfb12e87117ba85f4b4c01d07d7480772a SHA512 4f04245b8abef85de96a1527ad4adc1fadea144a1917db3ea21632a9fe732bdaa7021ffdbbeb7c2ead814ca7b6a14e81bb68a962bbfb64fa6809a235f1b0be5c
+DIST GraphicsMagick-1.3.32.tar.xz 5535224 BLAKE2B 96fd7bfe62b4b1b25f9ffc0ff8e2ac023f0528b9af857fc27a5a9cd1123eeb6533b868c7bad8dca5b58e114a674dda009a62904df64622d7b5f3c0d72156283d SHA512 f84cdb9318962aed1dc25d70db4d0ca102e4f88748f468f8a56b77d228fd315b772afa48e90a396d32e8226eba9105717bcb94166bbe43723afeec58ead53e09
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.32.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.32.ebuild
new file mode 100644 (file)
index 0000000..8b6bcca
--- /dev/null
@@ -0,0 +1,135 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+MY_P=${P/graphicsm/GraphicsM}
+
+DESCRIPTION="Collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.graphicsmagick.org/"
+LICENSE="MIT"
+SLOT="0/${PV%.*}"
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit mercurial
+       EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
+else
+       SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+IUSE="bzip2 cxx debug fpx imagemagick jbig jpeg jpeg2k lcms lzma modules openmp
+       perl png postscript q16 q32 static-libs svg test threads tiff truetype
+       webp wmf X zlib"
+
+RDEPEND="dev-libs/libltdl:0
+       bzip2? ( app-arch/bzip2 )
+       fpx? ( media-libs/libfpx )
+       imagemagick? ( !media-gfx/imagemagick )
+       jbig? ( media-libs/jbigkit )
+       jpeg? ( virtual/jpeg:0 )
+       jpeg2k? ( media-libs/jasper:= )
+       lcms? ( media-libs/lcms:2 )
+       lzma? ( app-arch/xz-utils )
+       perl? ( dev-lang/perl )
+       png? ( media-libs/libpng:0= )
+       postscript? ( app-text/ghostscript-gpl )
+       svg? ( dev-libs/libxml2 )
+       tiff? ( media-libs/tiff:0 )
+       truetype? (
+               media-fonts/urw-fonts
+               >=media-libs/freetype-2
+               )
+       webp? ( media-libs/libwebp:= )
+       wmf? ( media-libs/libwmf )
+       X? (
+               x11-libs/libSM
+               x11-libs/libXext
+               )
+       zlib? ( sys-libs/zlib )"
+# corefonts are required because needed arial font (bug #588398).
+DEPEND="${RDEPEND}
+       test? ( media-fonts/corefonts )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.3.19-flags.patch
+       "${FILESDIR}"/${PN}-1.3.19-perl.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local depth=8
+       use q16 && depth=16
+       use q32 && depth=32
+
+       local openmp=disable
+       if use openmp && tc-has-openmp; then
+               openmp=enable
+       fi
+
+       local myeconfargs=(
+               --${openmp}-openmp
+               --enable-largefile
+               --enable-shared
+               $(use_enable static-libs static)
+               $(use_enable debug prof)
+               $(use_enable debug gcov)
+               $(use_enable imagemagick magick-compat)
+               $(use_with threads)
+               $(use_with modules)
+               --with-quantum-depth=${depth}
+               --without-frozenpaths
+               $(use_with cxx magick-plus-plus)
+               $(use_with perl)
+               --with-perl-options=INSTALLDIRS=vendor
+               $(use_with bzip2 bzlib)
+               $(use_with postscript dps)
+               $(use_with fpx)
+               $(use_with jbig)
+               $(use_with webp)
+               $(use_with jpeg)
+               $(use_with jpeg2k jp2)
+               $(use_with lcms lcms2)
+               $(use_with lzma)
+               $(use_with png)
+               $(use_with tiff)
+               $(use_with truetype ttf)
+               $(use_with wmf)
+               --with-fontpath="${EPREFIX}"/usr/share/fonts
+               --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
+               --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
+               $(use_with svg xml)
+               $(use_with zlib)
+               $(use_with X x)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+       use perl && emake perl-build
+}
+
+src_test() {
+       unset DISPLAY # some perl tests fail when DISPLAY is set
+       default
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               emake -C PerlMagick DESTDIR="${D}" install
+               find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
+               find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
+       fi
+
+       find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
+}
index c5f11fb693d397dd8ae25bc4de1bcc93d911a903..8b6bccaf93cdb62ecf81294398f49b8e18eae4c9 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 inherit autotools toolchain-funcs
 
 MY_P=${P/graphicsm/GraphicsM}
@@ -33,7 +33,7 @@ RDEPEND="dev-libs/libltdl:0
        lcms? ( media-libs/lcms:2 )
        lzma? ( app-arch/xz-utils )
        perl? ( dev-lang/perl )
-       png? ( media-libs/libpng:0 )
+       png? ( media-libs/libpng:0= )
        postscript? ( app-text/ghostscript-gpl )
        svg? ( dev-libs/libxml2 )
        tiff? ( media-libs/tiff:0 )
@@ -92,7 +92,6 @@ src_configure() {
                $(use_with bzip2 bzlib)
                $(use_with postscript dps)
                $(use_with fpx)
-               --without-gslib
                $(use_with jbig)
                $(use_with webp)
                $(use_with jpeg)