dev-python/python-recaptcha: Version bump.
authorHanno <hanno@gentoo.org>
Fri, 23 Mar 2018 15:38:10 +0000 (16:38 +0100)
committerHanno <hanno@gentoo.org>
Fri, 23 Mar 2018 15:38:10 +0000 (16:38 +0100)
Namespace workaround no longer needed.

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-python/python-recaptcha/Manifest
dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild [new file with mode: 0644]

index 97c36aff4afebcec8c8c04203b6af7c9a5858444..b7180d077deb94b6d60a093feca49e9ee151c1a4 100644 (file)
@@ -1 +1,2 @@
 DIST python-recaptcha-2.0.0.tar.gz 5556 BLAKE2B b752915eb95343d7cbce483f49ce9d93ecf837c85a1615e414e14226c54dc60ede3187bd127e09769106a7eb06156ab2b73b0a3839743c29b6aba6e6c4d96951 SHA512 3a60062f36833888a110d5979ca7a7f46cef927bfcf427aba72d2f6a99a9c401b20bea997ff8fb2b8435876bed3880371a84568b95da1341940d275cba8ff178
+DIST python-recaptcha-2.0.1.tar.gz 5439 BLAKE2B e985affe7d008f0dda270c9251315cbe381fc2a72514a219f422a1405c41e3d621326cfa32285588d4b5785c0e21251370546847695815b77ede81812d8eddad SHA512 103c0cf65d67fe3e4d4ca5bb0a208ea221642b1a6c11ad1997e3f1cfa56360c81665fc593354f6ea776deea43cbf72c97f3376e2b77fc275332cddee8b3a9739
diff --git a/dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild b/dev-python/python-recaptcha/python-recaptcha-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..12afe92
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for reCAPTCHA and reCAPTCHA Mailhide"
+HOMEPAGE="https://github.com/redhat-infosec/python-recaptcha"
+SRC_URI="https://github.com/redhat-infosec/python-recaptcha/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+       dev-python/simplejson[${PYTHON_USEDEP}]
+       !dev-python/recaptcha-client"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"