Version bump, and remove old versions.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Wed, 13 Dec 2006 11:28:37 +0000 (11:28 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Wed, 13 Dec 2006 11:28:37 +0000 (11:28 +0000)
Package-Manager: portage-2.1.2_rc3-r4

net-p2p/rtorrent/ChangeLog
net-p2p/rtorrent/files/digest-rtorrent-0.7.0 [new file with mode: 0644]
net-p2p/rtorrent/rtorrent-0.7.0.ebuild [new file with mode: 0644]

index 76d085c9ed4756106bf085a96b3101903649c1ef..48d48509804664790b4e34c13fab337eabe47f66 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-p2p/rtorrent
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.65 2006/11/21 14:45:50 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.66 2006/12/13 11:28:37 flameeyes Exp $
+
+*rtorrent-0.7.0 (13 Dec 2006)
+
+  13 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> -rtorrent-0.5.3.ebuild,
+  -rtorrent-0.6.1.ebuild, -rtorrent-0.6.3.ebuild, -rtorrent-0.6.3-r1.ebuild,
+  +rtorrent-0.7.0.ebuild:
+  Version bump, and remove old versions.
 
   21 Nov 2006; Timothy Redaelli <drizzt@gentoo.org> metadata.xml:
   Added myself as co-maintainer.
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.7.0 b/net-p2p/rtorrent/files/digest-rtorrent-0.7.0
new file mode 100644 (file)
index 0000000..35321ef
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 26758f948874e1ee9732628772483b7b rtorrent-0.7.0.tar.gz 413247
+RMD160 8e0d598de52530d9483fc48096522019add75c5c rtorrent-0.7.0.tar.gz 413247
+SHA256 8e2d5f5a4476278d322a888d874152af16d8e4cf6b48f396eac4b65cd0cd9e9b rtorrent-0.7.0.tar.gz 413247
diff --git a/net-p2p/rtorrent/rtorrent-0.7.0.ebuild b/net-p2p/rtorrent/rtorrent-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..1361b3f
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.0.ebuild,v 1.1 2006/12/13 11:28:37 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.11.0
+       >=dev-libs/libsigc++-2.0
+       >=net-misc/curl-7.12
+       sys-libs/ncurses"
+DEPEND="${RDEPEND}
+       sys-devel/bc"
+
+src_compile() {
+       replace-flags -Os -O2
+
+       if [[ $(tc-arch) = "x86" ]]; then
+               filter-flags -fomit-frame-pointer -fforce-addr
+
+               # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+               # it could be safer to fallback to -O1, but with the high use of STL in
+               # rtorrent, that could make it too slow.
+               [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+       fi
+
+       econf \
+               $(use_enable debug) \
+               --disable-dependency-tracking \
+               || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+pkg_postinst() {
+       einfo "rtorrent now supports a configuration file."
+       einfo "A sample configuration file for rtorrent is can be found"
+       einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc AUTHORS README TODO doc/rtorrent.rc
+}