dev-python/memory_profiler: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Thu, 17 Dec 2015 13:30:01 +0000 (14:30 +0100)
committerJustin Lecher <jlec@gentoo.org>
Thu, 17 Dec 2015 14:48:46 +0000 (15:48 +0100)
Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/memory_profiler/Manifest
dev-python/memory_profiler/memory_profiler-0.40.ebuild [new file with mode: 0644]

index 51010f03772fdcb21f192a4def97c6bb73dc695e..6272156c1eee1d02f019fb9557bfe40e283593e9 100644 (file)
@@ -1 +1,2 @@
 DIST memory_profiler-0.39.tar.gz 27859 SHA256 61021f2dade7edd6cc09d7924bfdccc453bd1949608412a3e021d44a410d3a23 SHA512 aaf8bcb105bf7301af16a9f090b62177e608d93f1ec5ca51ca78005515943f216657dd316fcd60a56784dc65c879a605f9712723a810400ecc5685e01b3dcf72 WHIRLPOOL a329950674ff9f34a8152be257e282821c9282fb16b6df9484307717ac104dbbb107381bd0ccef53a35ab1391f2dbde04fb0de13c20e66c726cc7006dcc834e3
+DIST memory_profiler-0.40.tar.gz 28508 SHA256 95822fc82a288f3ebc1e0e91d8e33e7f80c2a691bb2ec5e8cca555c1350c5b8f SHA512 73f9849faae430225ea1f3b43c56e8d95d535ef4a85d0ddeb92aaba6a357fef72e76aca6f661d9ff0ac26a8ae14e6adff6ef0ecad1e5d0a22d6e262e7d657b25 WHIRLPOOL e88256260d74a4e5285509e55dccad3069b8cfaa0e21a0bcf4ba63043597176a5a4b15e7ef18c79d35bc8170b1879210bc95814b6246cecdffbd6b111ffb5b38
diff --git a/dev-python/memory_profiler/memory_profiler-0.40.ebuild b/dev-python/memory_profiler/memory_profiler-0.40.ebuild
new file mode 100644 (file)
index 0000000..9595e03
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="http://pypi.python.org/pypi/memory_profiler https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${REDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       ${EPYTHON} -m memory_profiler test/test_func.py || die
+       ${EPYTHON} -m memory_profiler test/test_loop.py || die
+       ${EPYTHON} -m memory_profiler test/test_as.py || die
+       ${EPYTHON} -m memory_profiler test/test_global.py || die
+       ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+       ${EPYTHON} test/test_import.py || die
+       ${EPYTHON} test/test_memory_usage.py || die
+       ${EPYTHON} test/test_precision_import.py || die
+}