sys-fs/zfs{,-devel}: Bump to 0.8.4
authorRichard Yao <ryao@gentoo.org>
Tue, 12 May 2020 19:06:41 +0000 (15:06 -0400)
committerRichard Yao <ryao@gentoo.org>
Tue, 12 May 2020 19:19:10 +0000 (15:19 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Richard Yao <ryao@gentoo.org>
sys-fs/zfs-kmod/Manifest
sys-fs/zfs-kmod/zfs-kmod-0.8.4.ebuild [new file with mode: 0644]
sys-fs/zfs/Manifest
sys-fs/zfs/zfs-0.8.4.ebuild [new file with mode: 0644]

index 5de6d1f5c7741dfe7844dc25703d130a379aadf4..222f29c3f81fd08daaa4d58aa07f103d51b4f4d3 100644 (file)
@@ -1,2 +1,3 @@
 DIST zfs-0.7.13.tar.gz 6614047 BLAKE2B c59c46287715779eb04d69333b0a417fa9865eb0d61c642b043188c4c97d4eed369f76a48327326ed1d4dd608ff95d91d20d26c80ed0b120a8fcd5f83cea638f SHA512 457d8f110b68c9656194cd3738b216d5d807d680e5cfc6ed1f3cf5ebde67860476387c6b862ba3ba7f972d8945075963e6c325543ab84468e3eff5dbce68476e
 DIST zfs-0.8.3.tar.gz 8779385 BLAKE2B 8b51b9d5b61543566bc7839d8452fdf9358442155e95f93a011531338824bbd4fc8879500e276b02d5d49d504a046728ecc0c6154f69eb7b47180b9bb0e46958 SHA512 aded632e6b04180560d4f2ff283260016e883dadae4e7fda9070b7113dee948099cb7a7b183f1c8139654389a2610fb9cc6f997acdc846040e605125cf016010
+DIST zfs-0.8.4.tar.gz 9285838 BLAKE2B 776bcd6dfab8825c07d315085e288b29bf543d6957325d5d566b7b78c04505dde9bd25eb6684cb4a1b6a657de8a4e1290d04d2b9079d26d6b834a70f1ec3b569 SHA512 9086dc6a6262dd93ca6ec43f1b4c2e5c804deba708c8a7460b8531aa4802b0bf8cac0917a1a00e6af2e96d4a21cd68b85e226bf571bd94041d0325c457106eb1
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.8.4.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.8.4.ebuild
new file mode 100644 (file)
index 0000000..3093f3b
--- /dev/null
@@ -0,0 +1,171 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic linux-mod toolchain-funcs
+
+DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
+HOMEPAGE="https://zfsonlinux.org/"
+
+if [[ ${PV} == "9999" ]]; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+else
+       SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/zfs-${PV}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~ppc64"
+       S="${WORKDIR}/zfs-${PV}"
+       ZFS_KERNEL_COMPAT="5.6"
+fi
+
+LICENSE="CDDL debug? ( GPL-2+ )"
+SLOT="0"
+IUSE="custom-cflags debug +rootfs"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+       !sys-kernel/spl
+"
+
+BDEPEND="
+       dev-lang/perl
+       virtual/awk
+"
+
+RESTRICT="debug? ( strip ) test"
+
+DOCS=( AUTHORS COPYRIGHT META README.md )
+
+pkg_setup() {
+       CONFIG_CHECK="
+               !DEBUG_LOCK_ALLOC
+               EFI_PARTITION
+               MODULES
+               !PAX_KERNEXEC_PLUGIN_METHOD_OR
+               !TRIM_UNUSED_KSYMS
+               ZLIB_DEFLATE
+               ZLIB_INFLATE
+       "
+
+       use debug && CONFIG_CHECK="${CONFIG_CHECK}
+               FRAME_POINTER
+               DEBUG_INFO
+               !DEBUG_INFO_REDUCED
+       "
+
+       use rootfs && \
+               CONFIG_CHECK="${CONFIG_CHECK}
+                       BLK_DEV_INITRD
+                       DEVTMPFS
+       "
+
+       if use arm64; then
+               kernel_is -ge 5 && CONFIG_CHECK="${CONFIG_CHECK} !PREEMPT"
+       fi
+
+       kernel_is -lt 5 && CONFIG_CHECK="${CONFIG_CHECK} IOSCHED_NOOP"
+
+       kernel_is -ge 3 10 || die "Linux 3.10 or newer required"
+
+       if [[ ${PV} != "9999" ]]; then
+               local kv_major_max kv_minor_max zcompat
+               zcompat="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
+               kv_major_max="${zcompat%%.*}"
+               zcompat="${zcompat#*.}"
+               kv_minor_max="${zcompat%%.*}"
+               kernel_is -le "${kv_major_max}" "${kv_minor_max}" || die \
+                       "Linux ${kv_major_max}.${kv_minor_max} is the latest supported version"
+       fi
+
+       linux-mod_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       if [[ ${PV} == "9999" ]]; then
+               eautoreconf
+       else
+               # Set module revision number
+               sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
+       fi
+}
+
+src_configure() {
+       set_arch_to_kernel
+
+       use custom-cflags || strip-flags
+
+       filter-ldflags -Wl,*
+
+       local myconf=(
+               --bindir="${EPREFIX}/bin"
+               --sbindir="${EPREFIX}/sbin"
+               --with-config=kernel
+               --with-linux="${KV_DIR}"
+               --with-linux-obj="${KV_OUT_DIR}"
+               $(use_enable debug)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       set_arch_to_kernel
+
+       myemakeargs=( V=1 )
+
+       emake "${myemakeargs[@]}"
+}
+
+src_install() {
+       set_arch_to_kernel
+
+       myemakeargs+=(
+               DEPMOD="/bin/true"
+               DESTDIR="${D}"
+               INSTALL_MOD_PATH="${INSTALL_MOD_PATH:-$EROOT}"
+       )
+
+       emake "${myemakeargs[@]}" install
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       linux-mod_pkg_postinst
+
+       # Remove old modules
+       if [[ -d "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" ]]; then
+               ewarn "${PN} now installs modules in ${EROOT}/lib/modules/${KV_FULL}/extra/zfs"
+               ewarn "Old modules were detected in ${EROOT}/lib/modules/${KV_FULL}/addon/zfs"
+               ewarn "Automatically removing old modules to avoid problems."
+               rm -r "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
+               rmdir --ignore-fail-on-non-empty "${EROOT}/lib/modules/${KV_FULL}/addon"
+       fi
+
+       if use x86 || use arm; then
+               ewarn "32-bit kernels will likely require increasing vmalloc to"
+               ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
+       fi
+
+       ewarn "This version of ZFSOnLinux includes support for new feature flags"
+       ewarn "that are incompatible with previous versions. GRUB2 support for"
+       ewarn "/boot with the new feature flags is not yet available."
+       ewarn "Do *NOT* upgrade root pools to use the new feature flags."
+       ewarn "Any new pools will be created with the new feature flags by default"
+       ewarn "and will not be compatible with older versions of ZFSOnLinux. To"
+       ewarn "create a newpool that is backward compatible wih GRUB2, use "
+       ewarn
+       ewarn "zpool create -d -o feature@async_destroy=enabled "
+       ewarn " -o feature@empty_bpobj=enabled -o feature@lz4_compress=enabled"
+       ewarn " -o feature@spacemap_histogram=enabled"
+       ewarn " -o feature@enabled_txg=enabled "
+       ewarn " -o feature@extensible_dataset=enabled -o feature@bookmarks=enabled"
+       ewarn " ..."
+       ewarn
+       ewarn "GRUB2 support will be updated as soon as either the GRUB2"
+       ewarn "developers do a tag or the Gentoo developers find time to backport"
+       ewarn "support from GRUB2 HEAD."
+}
index 5de6d1f5c7741dfe7844dc25703d130a379aadf4..222f29c3f81fd08daaa4d58aa07f103d51b4f4d3 100644 (file)
@@ -1,2 +1,3 @@
 DIST zfs-0.7.13.tar.gz 6614047 BLAKE2B c59c46287715779eb04d69333b0a417fa9865eb0d61c642b043188c4c97d4eed369f76a48327326ed1d4dd608ff95d91d20d26c80ed0b120a8fcd5f83cea638f SHA512 457d8f110b68c9656194cd3738b216d5d807d680e5cfc6ed1f3cf5ebde67860476387c6b862ba3ba7f972d8945075963e6c325543ab84468e3eff5dbce68476e
 DIST zfs-0.8.3.tar.gz 8779385 BLAKE2B 8b51b9d5b61543566bc7839d8452fdf9358442155e95f93a011531338824bbd4fc8879500e276b02d5d49d504a046728ecc0c6154f69eb7b47180b9bb0e46958 SHA512 aded632e6b04180560d4f2ff283260016e883dadae4e7fda9070b7113dee948099cb7a7b183f1c8139654389a2610fb9cc6f997acdc846040e605125cf016010
+DIST zfs-0.8.4.tar.gz 9285838 BLAKE2B 776bcd6dfab8825c07d315085e288b29bf543d6957325d5d566b7b78c04505dde9bd25eb6684cb4a1b6a657de8a4e1290d04d2b9079d26d6b834a70f1ec3b569 SHA512 9086dc6a6262dd93ca6ec43f1b4c2e5c804deba708c8a7460b8531aa4802b0bf8cac0917a1a00e6af2e96d4a21cd68b85e226bf571bd94041d0325c457106eb1
diff --git a/sys-fs/zfs/zfs-0.8.4.ebuild b/sys-fs/zfs/zfs-0.8.4.ebuild
new file mode 100644 (file)
index 0000000..3fbc4b3
--- /dev/null
@@ -0,0 +1,218 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
+
+DESCRIPTION="Userland utilities for ZFS Linux kernel module"
+HOMEPAGE="https://zfsonlinux.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+       inherit autotools git-r3 linux-mod
+       EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+else
+       SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${P}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~ppc64"
+fi
+
+LICENSE="BSD-2 CDDL MIT"
+SLOT="0"
+IUSE="custom-cflags debug kernel-builtin libressl python +rootfs test-suite static-libs"
+
+DEPEND="
+       ${PYTHON_DEPS}
+       net-libs/libtirpc[static-libs?]
+       sys-apps/util-linux[static-libs?]
+       sys-libs/zlib[static-libs(+)?]
+       virtual/awk
+       virtual/libudev[static-libs(-)?]
+       libressl? ( dev-libs/libressl:0=[static-libs?] )
+       !libressl? ( dev-libs/openssl:0=[static-libs?] )
+       python? (
+               virtual/python-cffi[${PYTHON_USEDEP}]
+       )
+"
+
+BDEPEND="virtual/awk
+       virtual/pkgconfig
+       python? (
+               dev-python/setuptools[${PYTHON_USEDEP}]
+       )
+"
+
+RDEPEND="${DEPEND}
+       !kernel-builtin? ( ~sys-fs/zfs-kmod-${PV} )
+       !prefix? ( virtual/udev )
+       sys-fs/udev-init-scripts
+       rootfs? (
+               app-arch/cpio
+               app-misc/pax-utils
+               !<sys-kernel/genkernel-3.5.1.1
+       )
+       test-suite? (
+               sys-apps/util-linux
+               sys-devel/bc
+               sys-block/parted
+               sys-fs/lsscsi
+               sys-fs/mdadm
+               sys-process/procps
+               virtual/modutils
+       )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+PATCHES=(
+       "${FILESDIR}/bash-completion-sudo.patch"
+)
+
+pkg_setup() {
+       if use kernel_linux && use test-suite; then
+               linux-info_pkg_setup
+
+               if  ! linux_config_exists; then
+                       ewarn "Cannot check the linux kernel configuration."
+               else
+                       if use test-suite; then
+                               if linux_chkconfig_present BLK_DEV_LOOP; then
+                                       eerror "The ZFS test suite requires loop device support enabled."
+                                       eerror "Please enable it:"
+                                       eerror "    CONFIG_BLK_DEV_LOOP=y"
+                                       eerror "in /usr/src/linux/.config or"
+                                       eerror "    Device Drivers --->"
+                                       eerror "        Block devices --->"
+                                       eerror "            [X] Loopback device support"
+                               fi
+                       fi
+               fi
+       fi
+}
+
+src_prepare() {
+       default
+
+       if [[ ${PV} == "9999" ]]; then
+               eautoreconf
+       else
+               # Set revision number
+               sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
+       fi
+
+       if use python; then
+               pushd contrib/pyzfs >/dev/null || die
+               distutils-r1_src_prepare
+               popd >/dev/null || die
+       fi
+
+       # prevent errors showing up on zfs-mount stop, #647688
+       # openrc will unmount all filesystems anyway.
+       sed -i "/^ZFS_UNMOUNT=/ s/yes/no/" "etc/default/zfs.in" || die
+}
+
+src_configure() {
+       use custom-cflags || strip-flags
+       python_setup
+
+       local myconf=(
+               --bindir="${EPREFIX}/bin"
+               --enable-shared
+               --enable-systemd
+               --enable-sysvinit
+               --localstatedir="${EPREFIX}/var"
+               --sbindir="${EPREFIX}/sbin"
+               --with-config=user
+               --with-dracutdir="${EPREFIX}/usr/lib/dracut"
+               --with-linux="${KV_DIR}"
+               --with-linux-obj="${KV_OUT_DIR}"
+               --with-udevdir="$(get_udevdir)"
+               --with-python="${EPYTHON}"
+               --with-systemdunitdir="$(systemd_get_systemunitdir)"
+               --with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
+               $(use_enable debug)
+               $(use_enable python pyzfs)
+               $(use_enable static-libs static)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       default
+       if use python; then
+               pushd contrib/pyzfs >/dev/null || die
+               distutils-r1_src_compile
+               popd >/dev/null || die
+       fi
+}
+
+src_install() {
+       default
+
+       gen_usr_ldscript -a uutil nvpair zpool zfs zfs_core
+
+       use test-suite || rm -rf "${ED}/usr/share/zfs"
+
+       if ! use static-libs; then
+               find "${ED}/" -name '*.la' -delete || die
+       fi
+
+       dobashcomp contrib/bash_completion.d/zfs
+       bashcomp_alias zfs zpool
+
+       # strip executable bit from conf.d file
+       fperms 0644 /etc/conf.d/zfs
+
+       if use python; then
+               pushd contrib/pyzfs >/dev/null || die
+               distutils-r1_src_install
+               popd >/dev/null || die
+       fi
+
+       # enforce best available python implementation
+       python_fix_shebang "${ED}/bin"
+
+}
+
+pkg_postinst() {
+       if use rootfs; then
+               if ! has_version sys-kernel/genkernel && ! has_version sys-kernel/dracut; then
+                       elog "root on zfs requires initramfs to boot"
+                       elog "the following packages known to provide one and tested on regular basis:"
+                       elog "  sys-kernel/dracut"
+                       elog "  sys-kernel/genkernel"
+               fi
+
+               if has_version "<=sys-kernel/genkernel-3.5.3.3"; then
+                       einfo "genkernel version 3.5.3.3 and earlier does NOT support"
+                       einfo " unlocking pools with native zfs encryption enabled at boot"
+                       einfo " use dracut or >=genkernel-4 if you requre this functionality"
+               fi
+       fi
+
+       if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then
+               einfo "Adding ${P} to the module database to ensure that the"
+               einfo "kernel modules and userland utilities stay in sync."
+               update_moduledb
+       fi
+
+       [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
+               einfo "You should add zfs-import to the boot runlevel."
+       [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
+               einfo "You should add zfs-mount to the boot runlevel."
+       [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
+               einfo "You should add zfs-share to the default runlevel."
+       [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
+               einfo "You should add zfs-zed to the default runlevel."
+}
+
+pkg_postrm() {
+       if ! use kernel-builtin && [[ ${PV} == "9999" ]]; then
+               remove_moduledb
+       fi
+}