sys-fs/xfsprogs: Bump to version 5.2.1
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 23 Aug 2019 01:06:09 +0000 (03:06 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 23 Aug 2019 01:13:58 +0000 (03:13 +0200)
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-fs/xfsprogs/Manifest
sys-fs/xfsprogs/xfsprogs-5.2.1.ebuild [new file with mode: 0644]

index 80f6644369e2c597291b1b8a5788b699725be0da..719651bf9debca06fe5adda196e5acfe00951433 100644 (file)
@@ -2,3 +2,4 @@ DIST xfsprogs-4.19.0.tar.xz 1212852 BLAKE2B 2d04390765c5e0dd7d51366f0310c9e68065
 DIST xfsprogs-5.0.0.tar.xz 1218476 BLAKE2B ef6eaab43531f696f739972c362e31c3304baaecb3485b45c16441a8bf7f1da7f47cd74a21660ba2c2bb45858a2b13b7af41c94671135f6a32a36eb745c024a0 SHA512 cebe3d2ea80676a99cc7f9cc014894398fbe3bdaf237829e9c7aa0404558c1ab16f2055acb5afd8234b2bc8475117bcef3c7500c553adb12bbaf3262bd077d18
 DIST xfsprogs-5.1.0.tar.xz 1223736 BLAKE2B bfadb13cf3a4f9231eb13f4e7d3c803c2143abb776c0fee758ea7257097ef3fb79253c16133942041c20ff6078a1704fa18d08866c6a2e1a61b63f4de11d00c7 SHA512 ca5959edb299be8574b2ca51e907a418fab796ae92f588075a2aab0c2a3cf8dae49e2b68679c65c361201223e8f8ac29b1e5618eb1e519496c3aca9218620881
 DIST xfsprogs-5.2.0.tar.xz 1225884 BLAKE2B bec075d2adbafc5f6be215b658b8617141ade481558477525251c8547162f462af5464af5ac25d9498aca99b960a59071cc6651c36c6d30e5757e8d177c1b898 SHA512 b65ffb4d293f1ee0a9ec5aa35bf7a9491c2d536ad0da7f8e1d533743caebd98abffd1b93508969bac4135dc15434a9e170a516cedd373466ef762b65029f013f
+DIST xfsprogs-5.2.1.tar.xz 1227012 BLAKE2B af6c25d88d0a50fc82ecb2d9d00545ffdf906d6e85361360130b5a2b0d362e566c097f15be04a61023bd5c7815b77d0bab6258d8f188c5afe68098c51ae26ee0 SHA512 a2ecd8e2ae8a4e7357b4133beaeffeae4d6c9d0ece9855d9780a84c2d4072e3d4e0b8ffa3baa995862ec38dcbc5dd74205f7f4456676826082c4811867508a43
diff --git a/sys-fs/xfsprogs/xfsprogs-5.2.1.ebuild b/sys-fs/xfsprogs/xfsprogs-5.2.1.ebuild
new file mode 100644 (file)
index 0000000..a546b73
--- /dev/null
@@ -0,0 +1,105 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs systemd
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="icu libedit nls readline"
+
+LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+       icu? ( dev-libs/icu:=[static-libs(+)] )
+       readline? ( sys-libs/readline:0=[static-libs(+)] )
+       !readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
+RDEPEND="${LIB_DEPEND//\[static-libs(+)]}
+       !<sys-fs/xfsdump-3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.9.0-underlinking.patch
+       "${FILESDIR}"/${PN}-4.15.0-sharedlibs.patch
+       "${FILESDIR}"/${PN}-4.15.0-docdir.patch
+)
+
+pkg_setup() {
+       if use readline && use libedit ; then
+               ewarn "You have USE='readline libedit' but these are exclusive."
+               ewarn "Defaulting to readline; please disable this USE flag if you want libedit."
+       fi
+}
+
+src_prepare() {
+       default
+
+       # Fix doc dir
+       sed -i \
+               -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+               include/builddefs.in || die
+
+       # Don't install compressed docs
+       sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
+}
+
+src_configure() {
+       export DEBUG=-DNDEBUG
+       export OPTIMIZER=${CFLAGS}
+       unset PLATFORM # if set in user env, this breaks configure
+
+       # Upstream does NOT support --disable-static anymore,
+       # https://www.spinics.net/lists/linux-xfs/msg30185.html
+       # https://www.spinics.net/lists/linux-xfs/msg30272.html
+       local myconf=(
+               --enable-blkid
+               --with-crond-dir="${EPREFIX}/etc/cron.d"
+               --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+               $(use_enable icu libicu)
+               $(use_enable nls gettext)
+               $(use_enable readline)
+               $(usex readline --disable-editline $(use_enable libedit editline))
+       )
+
+       if is-flagq -fno-lto ; then
+               einfo "LTO disabled via {C,CXX,F,FC}FLAGS"
+               myconf+=( --disable-lto )
+       else
+               if is-flagq -flto ; then
+                       einfo "LTO forced via {C,CXX,F,FC}FLAGS"
+                       myconf+=( --enable-lto )
+               elif use amd64 || use x86  ; then
+                       # match upstream default
+                       myconf+=( --enable-lto )
+               else
+                       # LTO can cause problems on some architectures, bug 655638
+                       myconf+=( --disable-lto )
+               fi
+       fi
+
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       # Unset {CF,LD}FLAGS which are already set via configure
+       # but will cause problems when available during make.
+       # Fixed in >=xfsprogs-5.3.0.
+       unset CFLAGS LDFLAGS
+
+       emake V=1
+}
+
+src_install() {
+       emake DIST_ROOT="${ED}" install 
+       emake DIST_ROOT="${ED}" install-dev
+
+       # removing unnecessary .la files if not needed
+       find "${ED}" -type f -name '*.la' -delete || die
+}