media-sound/gnome-music: bump to 3.34.5
authorMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 09:35:10 +0000 (12:35 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 09:55:38 +0000 (12:55 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-sound/gnome-music/Manifest
media-sound/gnome-music/gnome-music-3.34.5.ebuild [new file with mode: 0644]

index caf1caad3fc600dbe65274fc2b59d0f0270e17db..5ce3c500cd9c3586e13145578ccc8a4223850092 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnome-music-3.32.2.tar.xz 1391112 BLAKE2B ec64d48bcc137c69df77d9d9fadb3fa5c1809850e7a434d501cf6fd680500e57a4e6946ab591db9b715e728f0274f37b659afce53fd9213b3cf74f329f4373f3 SHA512 633748dcb5cf839f29059fd9bdd5283c455a4157d6c004168d9ef80352b83be3db547377034d0d78af0b6a84fec6fb941888bd53aa14c8bf51da880f04170a23
 DIST gnome-music-3.34.4.tar.xz 1412396 BLAKE2B 44899422b9a16de48b1435f139ff49f96a9d9e078354f2449ca551deac30b9b4d201e9dadcca700a44a170a6552559b8f06e80c6f248a37aba676dfe64cb7f4c SHA512 7d0450e63a890f10f825892a502b6fe5fbbae389b38e9487a768c50e632c82b89b29263cca2eef07abde429ebdcd1e140ec81ed748cdb643e94c2892f8e5d871
+DIST gnome-music-3.34.5.tar.xz 1415240 BLAKE2B 3545541171b023da116ebee5d28a2b69b6b45677cde26c833ea0992ba9bc41d4792375dbf3617105da53f0e98d21576e166980e896527a60d47c92690b343a27 SHA512 c4f3c8cd7e8a6d24d3766672acfe3abc340d0cd305ba0d3d0a87c02b5a5f9e8c47bee9d8284e76ad28c51eeebe56e3163f4e5c34c89e294801d0047b8476f80f
diff --git a/media-sound/gnome-music/gnome-music-3.34.5.ebuild b/media-sound/gnome-music/gnome-music-3.34.5.ebuild
new file mode 100644 (file)
index 0000000..fde8cf2
--- /dev/null
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Music management for Gnome"
+HOMEPAGE="https://wiki.gnome.org/Apps/Music"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+       >=dev-libs/glib-2.50:2
+       net-libs/gnome-online-accounts[introspection]
+       >=dev-libs/gobject-introspection-1.54:=
+       >=x11-libs/gtk+-3.24.7:3[introspection]
+       >=dev-libs/libdazzle-3.28.0[introspection]
+       >=media-libs/libmediaart-1.9.1:2.0[introspection]
+       net-libs/libsoup:2.4[introspection]
+       >=app-misc/tracker-2.2.0:=[introspection(+)]
+       $(python_gen_cond_dep '
+               >=dev-python/pygobject-3.29.1:3[cairo,${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pycairo-1.14.0[${PYTHON_MULTI_USEDEP}]
+       ')
+       >=media-libs/grilo-0.3.9:0.3[introspection]
+       >=media-plugins/grilo-plugins-0.3.9:0.3
+"
+# xdg-user-dirs-update needs to be there to create needed dirs
+# https://bugzilla.gnome.org/show_bug.cgi?id=731613
+RDEPEND="${DEPEND}
+       || (
+               >=app-misc/tracker-miners-2.2.0[gstreamer]
+               >=app-misc/tracker-miners-2.2.0[ffmpeg]
+       )
+       x11-libs/libnotify[introspection]
+       media-libs/gstreamer:1.0[introspection]
+       media-libs/gst-plugins-base:1.0[introspection]
+       media-plugins/gst-plugins-meta:1.0
+       media-plugins/grilo-plugins:0.3[tracker]
+       x11-misc/xdg-user-dirs
+"
+BDEPEND="
+       dev-libs/libxml2:2
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+RESTRICT="test" # only does desktop and appdata validation, and latter needs network to validate screenshot from https
+
+pkg_setup() {
+       python_setup
+}
+
+src_prepare() {
+       sed -e '/sys.path.insert/d' -i "${S}"/gnome-music.in || die "python fixup sed failed"
+       xdg_src_prepare
+}
+
+src_install() {
+       meson_src_install
+       python_fix_shebang "${D}"/usr/bin/gnome-music
+       python_optimize
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}