x11-libs/fox: revive fox-1.6 stable branch
authorJason A. Donenfeld <zx2c4@gentoo.org>
Sat, 28 Dec 2019 08:45:37 +0000 (09:45 +0100)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Sat, 28 Dec 2019 08:45:51 +0000 (09:45 +0100)
Things actually use it.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
profiles/package.mask
x11-libs/fox/fox-1.6.57-r1.ebuild [new file with mode: 0644]
x11-libs/fox/fox-1.6.57.ebuild [deleted file]

index 5f6a0b3e06828571d29e068d61a4d121940b24ef..c4dfd170ad5a99cebcfb9fe83f0ff202d4aa6682 100644 (file)
@@ -167,10 +167,8 @@ app-benchmarks/spew
 app-editors/adie
 dev-util/reswrap
 sci-calculators/calculator
-x11-libs/fox:1.6
 x11-misc/pathfinder
 x11-misc/shutterbug
-x11-misc/xfe
 
 # Michał Górny <mgorny@gentoo.org> (2019-12-15)
 # Live ebuild only.  Not touched since 2012.  Unsurprisingly,
diff --git a/x11-libs/fox/fox-1.6.57-r1.ebuild b/x11-libs/fox/fox-1.6.57-r1.ebuild
new file mode 100644 (file)
index 0000000..9320c30
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C++ Toolkit for developing Graphical User Interfaces easily and effectively"
+HOMEPAGE="http://www.fox-toolkit.org/"
+SRC_URI="ftp://ftp.fox-toolkit.org/pub/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib debug doc profile"
+
+RDEPEND="x11-libs/libXrandr
+       x11-libs/libXcursor
+       x11-libs/fox-wrapper
+       bzip2? ( app-arch/bzip2 )
+       jpeg? ( virtual/jpeg )
+       opengl? ( virtual/glu virtual/opengl )
+       png? ( media-libs/libpng:0= )
+       tiff? ( media-libs/tiff:0= )
+       truetype? ( media-libs/freetype:2
+               x11-libs/libXft )
+       zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto
+       x11-libs/libXt"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+       default
+
+       local d
+       for d in utils windows adie calculator pathfinder shutterbug; do
+               sed -i -e "s:${d}::" Makefile.am
+       done
+
+       # Respect system CXXFLAGS
+       sed -i -e 's:CXXFLAGS=""::' configure.ac || die "Unable to force cxxflags."
+
+       # don't strip binaries
+       sed -i -e '/LDFLAGS="-s ${LDFLAGS}"/d' configure.ac || die "Unable to prevent stripping."
+
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --enable-$(usex debug debug release) \
+               $(use_enable bzip2 bz2lib) \
+               $(use_enable jpeg) \
+               $(use_with opengl) \
+               $(use_enable png) \
+               $(use_enable tiff) \
+               $(use_with truetype xft) \
+               $(use_enable zlib) \
+               $(use_with profile profiling)
+}
+
+src_compile() {
+       emake
+       use doc && emake -C "${S}"/doc docs
+}
+
+src_install() {
+       emake install \
+               DESTDIR="${D}" \
+               htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+               artdir="${EPREFIX}"/usr/share/doc/${PF}/html/art \
+               screenshotsdir="${EPREFIX}"/usr/share/doc/${PF}/html/screenshots
+
+       CP="${ED}/usr/bin/ControlPanel"
+       if [[ -f ${CP} ]] ; then
+               mv "${CP}" "${ED}/usr/bin/fox-ControlPanel-${SLOT}" || \
+                       die "Failed to install ControlPanel"
+       fi
+
+       for doc in ADDITIONS AUTHORS LICENSE_ADDENDUM README TRACING ; do
+               [[ -f $doc ]] && dodoc $doc
+       done
+
+       # remove documentation if USE=-doc
+       use doc || rm -fr "${D}/usr/share/doc/${PF}/html"
+
+       # install class reference docs if USE=doc
+       if use doc && [[ -z ${FOX_COMPONENT} ]] ; then
+               docinto html
+               dodoc -r "${S}/doc/ref"
+       fi
+
+       # slot fox-config
+       if [[ -f ${D}/usr/bin/fox-config ]] ; then
+               mv "${D}/usr/bin/fox-config" "${D}/usr/bin/fox-${SLOT}-config" \
+               || die "failed to install fox-config"
+       fi
+}
diff --git a/x11-libs/fox/fox-1.6.57.ebuild b/x11-libs/fox/fox-1.6.57.ebuild
deleted file mode 100644 (file)
index 330f85c..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils fox
-
-LICENSE="LGPL-2.1"
-SLOT="1.6"
-KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
-
-RDEPEND="x11-libs/libXrandr
-       x11-libs/libXcursor
-       x11-libs/fox-wrapper
-       bzip2? ( >=app-arch/bzip2-1.0.2 )
-       jpeg? ( virtual/jpeg:= )
-       opengl? ( virtual/glu virtual/opengl )
-       png? ( >=media-libs/libpng-1.2.5:0= )
-       tiff? ( >=media-libs/tiff-3.5.7:0= )
-       truetype? ( =media-libs/freetype-2*
-               x11-libs/libXft )
-       zlib? ( >=sys-libs/zlib-1.1.4 )"
-DEPEND="${RDEPEND}
-       x11-base/xorg-proto
-       x11-libs/libXt"
-
-src_prepare() {
-       sed -i -e 's/-lXft/-lXft -lfontconfig/' "${S}/configure.ac"
-       fox_src_prepare
-}
-
-src_configure() {
-       FOXCONF="$(use_enable bzip2 bz2lib) \
-               $(use_enable jpeg) \
-               $(use_with opengl) \
-               $(use_enable png) \
-               $(use_enable tiff) \
-               $(use_with truetype xft) \
-               $(use_enable zlib)" fox_src_configure
-}